aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/obmenu/Makefile32
-rw-r--r--x11-wm/obmenu/distinfo3
-rw-r--r--x11-wm/obmenu/pkg-descr9
4 files changed, 45 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 863edbe89d4b..ab975ceb12b8 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -89,6 +89,7 @@
SUBDIR += nickleby
SUBDIR += novawm
SUBDIR += obconf
+ SUBDIR += obmenu
SUBDIR += olvwm
SUBDIR += openbox
SUBDIR += orion
diff --git a/x11-wm/obmenu/Makefile b/x11-wm/obmenu/Makefile
new file mode 100644
index 000000000000..d34ad035339d
--- /dev/null
+++ b/x11-wm/obmenu/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: obmenu
+# Date created: 2007-12-18
+# Whom: dougb
+#
+# $FreeBSD$
+#
+
+PORTNAME= obmenu
+PORTVERSION= 1.0
+CATEGORIES= x11-wm
+MASTER_SITES= SF
+
+MAINTAINER= dougb@FreeBSD.org
+COMMENT= Menu manager for Openbox supporting both static and pipe menus
+
+USE_XLIB= yes
+USE_GNOME= pygtk2
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= obMenu
+
+PORTDOCS= README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-wm/obmenu/distinfo b/x11-wm/obmenu/distinfo
new file mode 100644
index 000000000000..ff920f171d92
--- /dev/null
+++ b/x11-wm/obmenu/distinfo
@@ -0,0 +1,3 @@
+MD5 (obmenu-1.0.tar.gz) = 710036a5edc9886d6d563ce46c747432
+SHA256 (obmenu-1.0.tar.gz) = c9cea64d40d461a34ea3bdaec9867487c819d5f9814e1cc54db607d4d3c20e27
+SIZE (obmenu-1.0.tar.gz) = 26375
diff --git a/x11-wm/obmenu/pkg-descr b/x11-wm/obmenu/pkg-descr
new file mode 100644
index 000000000000..f62bf0a40717
--- /dev/null
+++ b/x11-wm/obmenu/pkg-descr
@@ -0,0 +1,9 @@
+Obmenu is a menu editor designed for Openbox. It's easy to use, allowing
+you to get the most out of the powerful Openbox menu system, while hiding
+the xml layout from the user.
+
+It can install dynamic menus (pipe menus), such as Gnome menus or a
+quick-navigator. You can also use the obxml module to easily write pipe
+menus of your own in Python.
+
+WWW: http://obmenu.sourceforge.net/