aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/penguinsap/Makefile10
-rw-r--r--audio/xmms-sapplug/Makefile8
2 files changed, 10 insertions, 8 deletions
diff --git a/audio/penguinsap/Makefile b/audio/penguinsap/Makefile
index a5d5405553e7..37a39bfc8c76 100644
--- a/audio/penguinsap/Makefile
+++ b/audio/penguinsap/Makefile
@@ -22,12 +22,12 @@ PLIST_FILES= bin/sap
.include <bsd.port.pre.mk>
-_CLANG!= clang --version | ${HEAD} -1 | ${SED} -e 's/.*clang version \([0-9]\)\.\([0-9]\).*/\1\2/'
+_CLANG!= ${CXX} --version | ${HEAD} -1 | ${SED} -e 's/.*clang version \([0-9]\)\.\([0-9]\).*/\1\2/'
+ISCLANG= ${_CLANG:M[34][0-9]}
-.if ${CXX:T} != "clang++"
-.if ${_CLANG} < 33
-CXXFLAGS+= --no-exceptions
-.endif
+# clang can build this without -fno-exceptions
+.if empty(ISCLANG)
+CXXFLAGS+= -fno-exceptions
.endif
post-patch:
diff --git a/audio/xmms-sapplug/Makefile b/audio/xmms-sapplug/Makefile
index e83381444f14..c6d7216da7b0 100644
--- a/audio/xmms-sapplug/Makefile
+++ b/audio/xmms-sapplug/Makefile
@@ -29,10 +29,12 @@ OPTIONS_DEFINE= OPTIMIZED_CFLAGS
.include <bsd.port.options.mk>
-_CLANG!= ${CC} --version | ${HEAD} -1 | ${SED} -e 's/.*clang version \([0-9]\)\.\([0-9]\).*/\1\2/'
+_CLANG!= ${CXX} --version | ${HEAD} -1 | ${SED} -e 's/.*clang version \([0-9]\)\.\([0-9]\).*/\1\2/'
+ISCLANG= ${_CLANG:M[34][0-9]}
-.if ${CXX:T} != "clang++" && !defined(_CLANG)
-CXXFLAGS+= --no-exceptions
+# clang can build this without -fno-exceptions
+.if empty(ISCLANG)
+CXXFLAGS+= -fno-exceptions
.endif
.if ${ARCH} == "amd64" || ${ARCH} == "ia64"