aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/fswiki/Makefile2
-rw-r--r--www/jdresolve/Makefile2
-rw-r--r--www/p5-CGI-EncryptForm/Makefile3
-rw-r--r--www/p5-Catalyst-Engine-PSGI/Makefile3
-rw-r--r--www/p5-Catalyst-Model-Memcached/Makefile3
-rw-r--r--www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/Makefile3
-rw-r--r--www/p5-GunghoX-FollowLinks/Makefile3
-rw-r--r--www/p5-HTML-Adsense/Makefile3
-rw-r--r--www/p5-HTML-Query/Makefile3
-rw-r--r--www/p5-HTML-Template-Associate/Makefile3
-rw-r--r--www/p5-HTML-Template-Pluggable/Makefile3
-rw-r--r--www/p5-Plack-Middleware-JSConcat/Makefile3
-rw-r--r--www/p5-Router-Simple-Sinatraish/Makefile3
-rw-r--r--www/p5-Template-Plugin-Monta/Makefile3
-rw-r--r--www/p5-W3C-LinkChecker/Makefile3
-rw-r--r--www/p5-WWW-OpenSVN/Makefile3
-rw-r--r--www/p5-WWW-Shorten-NotLong/Makefile3
-rw-r--r--www/p5-WWW-iTunesConnect/Makefile3
-rw-r--r--www/webstats/Makefile2
19 files changed, 35 insertions, 19 deletions
diff --git a/www/fswiki/Makefile b/www/fswiki/Makefile
index f1175b6fb24c..e4006c607337 100644
--- a/www/fswiki/Makefile
+++ b/www/fswiki/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= ja-p5-Jcode>=0:${PORTSDIR}/japanese/p5-Jcode \
p5-HTML-Template>=0:${PORTSDIR}/www/p5-HTML-Template
USE_ZIP= yes
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
post-extract:
diff --git a/www/jdresolve/Makefile b/www/jdresolve/Makefile
index 387256b7c378..7cd609713124 100644
--- a/www/jdresolve/Makefile
+++ b/www/jdresolve/Makefile
@@ -19,7 +19,7 @@ COMMENT= A IP addresse to hostname program for httpd log files
BUILD_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
MANCOMPRESSED= no
diff --git a/www/p5-CGI-EncryptForm/Makefile b/www/p5-CGI-EncryptForm/Makefile
index 2efb7b493644..9f56e146553b 100644
--- a/www/p5-CGI-EncryptForm/Makefile
+++ b/www/p5-CGI-EncryptForm/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-Crypt-HCE_SHA>=0:${PORTSDIR}/security/p5-Crypt-HCE_SHA \
p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= CGI::EncryptForm.3
diff --git a/www/p5-Catalyst-Engine-PSGI/Makefile b/www/p5-Catalyst-Engine-PSGI/Makefile
index 397c199c1126..8b1b885cedfa 100644
--- a/www/p5-Catalyst-Engine-PSGI/Makefile
+++ b/www/p5-Catalyst-Engine-PSGI/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= \
p5-Catalyst-Action-RenderView>0:${PORTSDIR}/www/p5-Catalyst-Action-RenderView
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Controller::Metal.3 \
Catalyst::Engine::PSGI.3 \
diff --git a/www/p5-Catalyst-Model-Memcached/Makefile b/www/p5-Catalyst-Model-Memcached/Makefile
index 8353d4f67a94..a830cefabf74 100644
--- a/www/p5-Catalyst-Model-Memcached/Makefile
+++ b/www/p5-Catalyst-Model-Memcached/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-Cache-Memcached-Fast>=0.17:${PORTSDIR}/databases/p5-Cache-Memcac
p5-Catalyst-Runtime>=5.8:${PORTSDIR}/www/p5-Catalyst-Runtime
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Catalyst::Model::Memcached.3
diff --git a/www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/Makefile b/www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/Makefile
index 950257f6c3ae..af600f4dff42 100644
--- a/www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/Makefile
+++ b/www/p5-Catalyst-Plugin-Session-Store-Memcached-Fast/Makefile
@@ -21,7 +21,8 @@ BUILD_DEPENDS= p5-Cache-Memcached-Fast>=0:${PORTSDIR}/databases/p5-Cache-Memcach
p5-Class-Data-Inheritable>=0:${PORTSDIR}/devel/p5-Class-Data-Inheritable
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Catalyst::Plugin::Session::Store::Memcached::Fast.3
diff --git a/www/p5-GunghoX-FollowLinks/Makefile b/www/p5-GunghoX-FollowLinks/Makefile
index e0e0236730a5..4531852ce01c 100644
--- a/www/p5-GunghoX-FollowLinks/Makefile
+++ b/www/p5-GunghoX-FollowLinks/Makefile
@@ -25,7 +25,8 @@ RUN_DEPENDS= \
BUILD_DEPENDS:= ${RUN_DEPENDS}
TEST_DEPENDS= p5-Class-Null>0:${PORTSDIR}/devel/p5-Class-Null
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= GunghoX::FollowLinks.3 \
GunghoX::FollowLinks::Filter.3 \
diff --git a/www/p5-HTML-Adsense/Makefile b/www/p5-HTML-Adsense/Makefile
index cbf120c0db0b..7d4ea84036ce 100644
--- a/www/p5-HTML-Adsense/Makefile
+++ b/www/p5-HTML-Adsense/Makefile
@@ -17,7 +17,8 @@ COMMENT= Create adsense widgets easily
RUN_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::Adsense.3
diff --git a/www/p5-HTML-Query/Makefile b/www/p5-HTML-Query/Makefile
index 47887ec26e30..fbaf8add4cca 100644
--- a/www/p5-HTML-Query/Makefile
+++ b/www/p5-HTML-Query/Makefile
@@ -17,7 +17,8 @@ COMMENT= JQuery-like selection queries for HTML::Element
RUN_DEPENDS+= p5-Badger>0.0:${PORTSDIR}/devel/p5-Badger \
p5-HTML-Tree>=3.23:${PORTSDIR}/www/p5-HTML-Tree
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::Query.3
PLIST_FILES= %%SITE_PERL%%/HTML/Query.pm \
diff --git a/www/p5-HTML-Template-Associate/Makefile b/www/p5-HTML-Template-Associate/Makefile
index b6eee6ef088c..7b907ff19ec2 100644
--- a/www/p5-HTML-Template-Associate/Makefile
+++ b/www/p5-HTML-Template-Associate/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-HTML-Template>=0:${PORTSDIR}/www/p5-HTML-Template \
p5-Data-FormValidator>=0:${PORTSDIR}/textproc/p5-Data-FormValidator
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::Template::Associate.3 \
HTML::Template::Associate::DBI.3 \
diff --git a/www/p5-HTML-Template-Pluggable/Makefile b/www/p5-HTML-Template-Pluggable/Makefile
index 93ff90289b18..eab0fe7be9ba 100644
--- a/www/p5-HTML-Template-Pluggable/Makefile
+++ b/www/p5-HTML-Template-Pluggable/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-HTML-Template>=2.7:${PORTSDIR}/www/p5-HTML-Template \
p5-Class-Trigger>=0:${PORTSDIR}/devel/p5-Class-Trigger
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= HTML::Template::Pluggable.3 \
HTML::Template::Plugin::Dot.3
diff --git a/www/p5-Plack-Middleware-JSConcat/Makefile b/www/p5-Plack-Middleware-JSConcat/Makefile
index 5524f42dfdc7..935b3f011a9d 100644
--- a/www/p5-Plack-Middleware-JSConcat/Makefile
+++ b/www/p5-Plack-Middleware-JSConcat/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= \
p5-Plack>0:${PORTSDIR}/www/p5-Plack
BUILD_DEPENDS:= ${RUN_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Plack::Middleware::JSConcat.3
diff --git a/www/p5-Router-Simple-Sinatraish/Makefile b/www/p5-Router-Simple-Sinatraish/Makefile
index 927d50efd02f..c044c5403313 100644
--- a/www/p5-Router-Simple-Sinatraish/Makefile
+++ b/www/p5-Router-Simple-Sinatraish/Makefile
@@ -13,7 +13,8 @@ RUN_DEPENDS= \
p5-Router-Simple>=0.09:${PORTSDIR}/www/p5-Router-Simple
BUILD_DEPENDS= ${RUN_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Router::Simple::Sinatraish.3
diff --git a/www/p5-Template-Plugin-Monta/Makefile b/www/p5-Template-Plugin-Monta/Makefile
index 80c3e58a8cfa..55dded1e17cb 100644
--- a/www/p5-Template-Plugin-Monta/Makefile
+++ b/www/p5-Template-Plugin-Monta/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-Template-Toolkit>=0:${PORTSDIR}/www/p5-Template-Toolkit
RUN_DEPENDS:= ${BUILD_DEPENDS} \
p5-Acme-Monta>=0:${PORTSDIR}/www/p5-Acme-Monta
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Template::Plugin::Monta.3
diff --git a/www/p5-W3C-LinkChecker/Makefile b/www/p5-W3C-LinkChecker/Makefile
index a30395762b45..875575cc1cf8 100644
--- a/www/p5-W3C-LinkChecker/Makefile
+++ b/www/p5-W3C-LinkChecker/Makefile
@@ -28,6 +28,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN1= checklink.1
MANCOMPRESSED= no
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/www/p5-WWW-OpenSVN/Makefile b/www/p5-WWW-OpenSVN/Makefile
index 280bff42c05e..9d505c74e341 100644
--- a/www/p5-WWW-OpenSVN/Makefile
+++ b/www/p5-WWW-OpenSVN/Makefile
@@ -17,7 +17,8 @@ COMMENT= An automated interface for OpenSVN.csie.org
BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= WWW::OpenSVN.3
diff --git a/www/p5-WWW-Shorten-NotLong/Makefile b/www/p5-WWW-Shorten-NotLong/Makefile
index e2a291461ec4..42b5c790cbd9 100644
--- a/www/p5-WWW-Shorten-NotLong/Makefile
+++ b/www/p5-WWW-Shorten-NotLong/Makefile
@@ -21,6 +21,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= WWW::Shorten::NotLong.3
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/www/p5-WWW-iTunesConnect/Makefile b/www/p5-WWW-iTunesConnect/Makefile
index e82fb8af9e57..53b9e92fc603 100644
--- a/www/p5-WWW-iTunesConnect/Makefile
+++ b/www/p5-WWW-iTunesConnect/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= p5-HTML-Tree>=0:${PORTSDIR}/www/p5-HTML-Tree \
p5-HTML-Form>=0:${PORTSDIR}/www/p5-HTML-Form
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= YES
+USES= perl5
+USE_PERL5= configure
MAN3= WWW::iTunesConnect.3
diff --git a/www/webstats/Makefile b/www/webstats/Makefile
index 8a3752f8148a..a5d7b666d6cf 100644
--- a/www/webstats/Makefile
+++ b/www/webstats/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= analog:${PORTSDIR}/www/analog \
${LOCALBASE}/reportmagic/rmagic.pl:${PORTSDIR}/www/reportmagic
NO_BUILD= yes
-USE_PERL5= yes
+USES= perl5
post-patch:
@${REINPLACE_CMD} -i '' -e 's|%%PREFIX%%|${PREFIX}|' \