aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 5ea40e5cb77f..d89e2daed479 100644
--- a/Makefile
+++ b/Makefile
@@ -164,7 +164,15 @@ print-index: ${INDEXDIR}/${INDEXFILE}
@awk -F\| '{ printf("Port:\t%s\nPath:\t%s\nInfo:\t%s\nMaint:\t%s\nIndex:\t%s\nB-deps:\t%s\nR-deps:\t%s\nE-deps:\t%s\nP-deps:\t%s\nF-deps:\t%s\nWWW:\t%s\n\n", $$1, $$2, $$4, $$6, $$7, $$8, $$9, $$11, $$12, $$13, $$10); }' < ${INDEXDIR}/${INDEXFILE}
GIT?= git
-SVN?= svn
+.if !defined(SVN) || empty(SVN)
+. for _P in /usr/bin /usr/local/bin
+. for _S in svn svnlite
+. if exists(${_P}/${_S})
+SVN= ${_P}/${_S}
+. endif
+. endfor
+. endfor
+.endif
RSYNC?= rsync
PORTSNAP?= portsnap
PORTSNAP_FLAGS?= -p ${.CURDIR}