aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses/shebangfix.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/Uses/shebangfix.mk')
-rw-r--r--Mk/Uses/shebangfix.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/Mk/Uses/shebangfix.mk b/Mk/Uses/shebangfix.mk
index 6ae6d8d0e96e..c2543e72af90 100644
--- a/Mk/Uses/shebangfix.mk
+++ b/Mk/Uses/shebangfix.mk
@@ -84,13 +84,15 @@ fix-shebang:
@cd ${WRKSRC}; \
${FIND} -E . -type f -iregex '${SHEBANG_REGEX}' \
-exec ${SED} -i '' ${_SHEBANG_REINPLACE_ARGS} {} +
-.elif defined(SHEBANG_GLOB)
-.for f in ${SHEBANG_GLOB}
+.endif
+.if defined(SHEBANG_GLOB)
+. for f in ${SHEBANG_GLOB}
@cd ${WRKSRC}; \
${FIND} . -type f -name '${f}' \
-exec ${SED} -i '' ${_SHEBANG_REINPLACE_ARGS} {} +
-.endfor
-.else
+. endfor
+.endif
+.if defined(SHEBANG_FILES)
@cd ${WRKSRC}; \
${ECHO_CMD} ${SHEBANG_FILES} | ${XARGS} ${SED} -i '' ${_SHEBANG_REINPLACE_ARGS}
.endif