aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/gecko.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/Mk/Uses/gecko.mk b/Mk/Uses/gecko.mk
index eabf5167f67f..45af2be93ee3 100644
--- a/Mk/Uses/gecko.mk
+++ b/Mk/Uses/gecko.mk
@@ -31,18 +31,18 @@ GECKO_CONFING?= ${LOCALBASE}/bin/${GECKO}-config
XPIDL?= ${LOCALBASE}/lib/${GECKO}/xpidl
XPIDL_INCL?= `${GECKO_CONFIG} --idlflags`
-BUILD_DEPENDS+= libxul>=31:${PORTSDIR}/www/libxul
-RUN_DEPENDS+= libxul>=31:${PORTSDIR}/www/libxul
+BUILD_DEPENDS+= libxul>=38:${PORTSDIR}/www/libxul
+RUN_DEPENDS+= libxul>=38:${PORTSDIR}/www/libxul
.elif ${gecko_ARGS:Mfirefox}
-_GECKO_DEFAULT_VERSION= 31
-_GECKO_VERSIONS= 31 38
+_GECKO_DEFAULT_VERSION= 38
+_GECKO_VERSIONS= 38 39
_GECKO_TYPE= firefox
# Dependence lines for different Firefox versions
-31_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox-esr
-38_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
+38_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox-esr
+39_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
.if exists(${LOCALBASE}/bin/firefox)
_GECKO_INSTALLED_VER!= ${LOCALBASE}/bin/firefox --version 2>/dev/null