aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/pyqt.mk51
1 files changed, 38 insertions, 13 deletions
diff --git a/Mk/Uses/pyqt.mk b/Mk/Uses/pyqt.mk
index 72cae36f8ff9..4aaee34ec2c2 100644
--- a/Mk/Uses/pyqt.mk
+++ b/Mk/Uses/pyqt.mk
@@ -16,11 +16,10 @@
# * foo_build only build depend
# * foo_run only run depend
# * foo both (default)
-# SIPDIR - Absolute path where sip files will be installed
-# SIPDIR_REL - Relative version of SIPDIR
-#
-# Also PYQT_SIPDIR=${SIPDIR_REL} will be added to PLIST_SUB.
-#
+# PYQT_SIPDIR - where sip files will be installed to
+# PYQT_APIDIR - where api files will be installed to
+# PYQT_DOCDIR - where doc files will be installed to
+# PYQT_EXAMPLESDIR - where examples will be installed to
.if !defined(_INCLUDE_USES_PYQT_MK)
_INCLUDE_USES_PYQT_MK= yes
@@ -64,7 +63,7 @@ MASTER_SITES_QSCI2= SF/pyqt/QScintilla2/QScintilla-${PORTVERSION} \
SIP_VERSION= 4.19.8
QSCI2_VERSION= 2.10.4
PYQT4_VERSION= 4.12.1
-PYQT5_VERSION= 5.9.2
+PYQT5_VERSION= 5.10.1
SIP_DISTNAME= sip-${SIP_VERSION}
PYQT4_DISTNAME= PyQt4_gpl_x11-${PYQT4_VERSION}
@@ -205,9 +204,32 @@ py-serialport_DESC= Python bindings for QtSerialPort
py-webkitwidgets_DESC= Python bindings for QtWebKitWidgets module
py-widgets_DESC= Python bindings for QTWidgets module
-SIPDIR_REL= share/py-sip/PyQt${_PYQT_VERSION}
-SIPDIR= ${PREFIX}/${SIPDIR_REL}
-PLIST_SUB+= PYQT_SIPDIR=${SIPDIR_REL}
+# The versionned executable of sip
+SIP= ${LOCALBASE}/bin/sip-${PYTHON_VER}
+
+# Relative directories
+_VERSION_SUBDIR_REL= PyQt${_PYQT_VERSION}/${PYTHON_VER}
+_APIDIR_REL= share/${_VERSION_SUBDIR_REL}/qsci
+_DOCDIR_REL= share/doc/${_VERSION_SUBDIR_REL}
+_EXAMPLEDIR_REL= share/examples/${_VERSION_SUBDIR_REL}
+_SIPDIR_REL= share/${_VERSION_SUBDIR_REL}/sip
+_DESIGNERDIR_REL= ${QT_PLUGINDIR_REL}/designer/${_VERSION_SUBDIR_REL}
+_QMLDIR_REL= ${QT_QMLDIR_REL}/${_VERSION_SUBDIR_REL}
+
+# Absolute direcotries
+PYQT_APIDIR= ${PREFIX}/${_APIDIR_REL}
+PYQT_DOCDIR= ${PREFIX}/${_DOCDIR_REL}
+PYQT_EXAMPLEDIR= ${PREFIX}/${_EXAMPLEDIR_REL}
+PYQT_SIPDIR= ${PREFIX}/${_SIPDIR_REL}
+PYQT_DESIGNERDIR= ${PREFIX}/${_DESIGNERDIR_REL}
+PYQT_QMLDIR= ${PREFIX}/${_QMLDIR_REL}
+
+PLIST_SUB+= PYQT_APIDIR=${_APIDIR_REL} \
+ PYQT_DOCDIR=${_DOCDIR_REL} \
+ PYQT_EXAMPLEDIR=${_EXAMPLEDIR_REL} \
+ PYQT_SIPDIR=${_SIPDIR_REL} \
+ PYQT_DESIGNERDIR=${_DESIGNERDIR_REL} \
+ PYQT_QMLDIR=${_QMLDIR_REL}
.if defined(PYQT_DIST)
PORTVERSION= ${PYQT_VERSION}
@@ -227,14 +249,17 @@ PORTSCOUT?= limit:^${_QT_VERSION:R}
.endif
PATCHDIR= ${.CURDIR}/../../devel/${PYQT_RELNAME}-core/files
-QSCIDIR= ${PREFIX}/share/qt${_PYQT_VERSION}/qsci
CONFIGURE_ARGS+=-b ${PREFIX}/bin \
-d ${PYTHONPREFIX_SITELIBDIR} \
-q ${QMAKE} \
--confirm-license \
- --sip ${LOCALBASE}/bin/sip-${PYTHON_VER} \
- --sipdir ${SIPDIR}
-
+ --sip ${SIP} \
+ --sipdir ${PYQT_SIPDIR}
+# Move the designer plugin and qml libraries to versioned folders.
+.if ${_PYQT_VERSION:M5}
+CONFIGURE_ARGS+=--qml-plugindir ${PYQT_QMLDIR} \
+ --designer-plugindir ${PYQT_DESIGNERDIR}
+.endif
# One of the things PyQt looks for to determine whether to build the Qt DBus
# main loop module (${PYQT_RELNAME}-dbussupport) is whether the dbus/ directory is
# present. Only extract it for that port then.