aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.gnome.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/bsd.gnome.mk')
-rw-r--r--Mk/bsd.gnome.mk16
1 files changed, 4 insertions, 12 deletions
diff --git a/Mk/bsd.gnome.mk b/Mk/bsd.gnome.mk
index 6664b5cd85f8..4457d18c0f8a 100644
--- a/Mk/bsd.gnome.mk
+++ b/Mk/bsd.gnome.mk
@@ -26,7 +26,7 @@ Gnome_Include_MAINTAINER= gnome@FreeBSD.org
# non-version specific components
_USE_GNOME_ALL= gnomehack lthack gnomeprefix gnomehier esound gnomemimedata \
- gnometarget pkgconfig intltool intlhack
+ gnometarget pkgconfig intlhack
# GNOME 1 components
_USE_GNOME_ALL+=libghttp glib12 gtk12 libxml gdkpixbuf imlib orbit \
@@ -41,8 +41,7 @@ _USE_GNOME_ALL+=glib20 atk pango gtk20 linc libidl orbit2 \
libgnome libbonoboui libgnomeui atspi libgailgnome \
libgtkhtml gnomedesktop libwnck vte libzvt librsvg2 eel2 \
gnomepanel nautilus2 metacity gal2 gnomecontrolcenter2 libgda2 \
- libgnomedb gtksourceview libgsf pygtk2 pygnome2 gstreamerplugins \
- gtkhtml3
+ libgnomedb gtksourceview libgsf pygtk2 pygnome2 gstreamerplugins
SCROLLKEEPER_DIR= /var/db/scrollkeeper
gnomehack_PRE_PATCH= ${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
@@ -234,7 +233,7 @@ pango_USE_GNOME_IMPL= glib20
gtk20_LIB_DEPENDS= gtk-x11-2.0.200:${PORTSDIR}/x11-toolkits/gtk20
gtk20_DETECT= ${X11BASE}/libdata/pkgconfig/gtk+-x11-2.0.pc
-gtk20_USE_GNOME_IMPL= intltool atk pango
+gtk20_USE_GNOME_IMPL= atk pango
linc_LIB_DEPENDS= linc.1:${PORTSDIR}/net/linc
linc_DETECT= ${LOCALBASE}/libdata/pkgconfig/linc.pc
@@ -398,17 +397,10 @@ gstreamerplugins_LIB_DEPENDS= gstplay-0.6.1:${PORTSDIR}/multimedia/gstreamer-plu
gstreamerplugins_DETECT= ${X11BASE}/libdata/pkgconfig/gstreamer-play-0.6.pc
gstreamerplugins_USE_GNOME_IMPL= gconf2
-intltool_DETECT= ${LOCALBASE}/bin/intltool-extract
-intltool_BUILD_DEPENDS= ${intltool_DETECT}:${PORTSDIR}/textproc/intltool
-
+intlhack_BUILD_DEPENDS= intltool-extract:${PORTSDIR}/textproc/intltool
intlhack_PRE_PATCH= ${FIND} ${WRKSRC} -name "intltool-merge.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|mkdir $$lang or|mkdir $$lang, 0777 or| ; \
s|^push @INC, "/.*|push @INC, "${LOCALBASE}/share/intltool";|'
-intlhack_USE_GNOME_IMPL=intltool
-
-gtkhtml3_LIB_DEPENDS= gtkhtml-3.0.3:${PORTSDIR}/www/gtkhtml3
-gtkhtml3_DETECT= ${X11BASE}/libdata/pkgconfig/libgtkhtml-3.0.pc
-gtkhtml3_USE_GNOME_IMPL=gal2 gail
# End component definition section