aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 470a2121b2d3..a974d9999074 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4728,12 +4728,12 @@ fetch-url-list-int:
.if !target(fetch-urlall-list)
fetch-urlall-list:
- @LISTALL=yes ${MAKE} fetch-url-list-int
+ @cd ${.CURDIR} && LISTALL=yes ${MAKE} fetch-url-list-int
.endif
.if !target(fetch-url-list)
fetch-url-list:
- @${MAKE} fetch-url-list-int
+ @cd ${.CURDIR} && ${MAKE} fetch-url-list-int
.endif
# Generates patches.
@@ -6010,7 +6010,7 @@ sanity-config: _check-config
[Nn]|[Nn][Oo]) \
exit 0; \
esac; \
- ${MAKE} config
+ cd ${.CURDIR} && ${MAKE} config
.endif
.endif # sanity-config
@@ -6101,7 +6101,7 @@ config: pre-config
${CAT} $${TMPOPTIONSFILE} > ${OPTIONSFILE}; \
fi; \
${RM} -f $${TMPOPTIONSFILE}
- @${MAKE} sanity-config
+ @cd ${.CURDIR} && ${MAKE} sanity-config
.endif
.endif # config