aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 1b772b6a1118..746f484f8100 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3432,7 +3432,7 @@ do-fetch:
esac; \
if ${SETENV} ${FETCH_ENV} ${FETCH_CMD} ${FETCH_BEFORE_ARGS} $${args} ${FETCH_AFTER_ARGS}; then \
actual_size=`stat -f %z "$${file}"`; \
- if [ $${actual_size} -eq $${CKSIZE} ]; then \
+ if [ -n "${DISABLE_SIZE}" ] || [ $${actual_size} -eq $${CKSIZE} ]; then \
continue 2; \
else \
${ECHO_MSG} "=> Fetched file size mismatch (expected $${CKSIZE}, actual $${actual_size})"; \