aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.python.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/bsd.python.mk')
-rw-r--r--Mk/bsd.python.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/Mk/bsd.python.mk b/Mk/bsd.python.mk
index c75e4b04f0b7..f8951fc90f45 100644
--- a/Mk/bsd.python.mk
+++ b/Mk/bsd.python.mk
@@ -87,6 +87,12 @@ Python_Include_MAINTAINER= python@FreeBSD.org
# in case you want to use an older version as a default.
# default: python2.7
#
+# PYTHON3_DEFAULT_VERSION
+# - Version of the default python binary in your ${PATH}, in
+# the format "python3.2". Set this in your /etc/make.conf
+# in case you want to use an older version as a default.
+# default: python3.3
+#
# PYTHON_MAJOR_VER - Python version major number. 2 for python-2.x,
# 3 for python-3.x and so on.
#
@@ -274,6 +280,12 @@ _PYTHON_DEFAULT_VERSION= ${_PYTHON_PORTBRANCH}
PYTHON_DEFAULT_VERSION= python${_PYTHON_DEFAULT_VERSION}
.endif
+.if ${PYTHON_DEFAULT_VERSION:R} == "python3"
+PYTHON3_DEFAULT_VERSION= ${PYTHON_DEFAULT_VERSION}
+.else
+PYTHON3_DEFAULT_VERSION= python3.3
+.endif
+
.if defined(PYTHON_VERSION)
_PYTHON_VERSION:= ${PYTHON_VERSION:S/^python//}
_PYTHON_CMD= ${LOCALBASE}/bin/${PYTHON_VERSION}