aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gstreamer.mk20
1 files changed, 13 insertions, 7 deletions
diff --git a/Mk/bsd.gstreamer.mk b/Mk/bsd.gstreamer.mk
index 562cf6767ace..42c25bc1e33a 100644
--- a/Mk/bsd.gstreamer.mk
+++ b/Mk/bsd.gstreamer.mk
@@ -55,14 +55,14 @@ GST_SHLIB_VERSION= 1
GSTREAMER1_PORT= ${PORTSDIR}/multimedia/gstreamer1-plugins
_GST1_LIB_BASE= ${LOCALBASE}/lib/gstreamer-${GST1_VERSION}
-GST1_VERSION= 1.2
+GST1_VERSION= 1.4
GST1_MINOR_VERSION= .0
GST1_SHLIB_VERSION= 0
GST1_MINIMAL_VERSION= .0
#
# missing base: alsa ivorbisdec
-# missing good: pulseaudio(need newer pulse version)
+# missing good: -
# missing ugly: -
# missing bad: openal
@@ -71,9 +71,9 @@ GST1_MINIMAL_VERSION= .0
_GSTREAMER_PLUGINS= \
a52dec aalib amrnb amrwbdec cairo cdio \
cdparanoia dts dv faac faad flac flite \
- gdkpixbuf gme gnonlin gsm jack jpeg lame libcaca \
+ gdkpixbuf gl gme gnonlin gsm jack jpeg lame libcaca \
libmms libvisual mad mpeg2dec mpeg2enc neon ogg \
- opencv opus pango resindvd schroedinger \
+ opencv opus pango pulse resindvd schroedinger \
shout2 sidplay soundtouch soup speex taglib \
theora twolame v4l2 vorbis wavpack x264
@@ -81,15 +81,16 @@ _GSTREAMER_PLUGINS= \
.if defined(USE_GSTREAMER)
_GSTREAMER_PLUGINS+= \
annodex bz2 cdaudio dvd esound ffmpeg fluendo-mp3 \
- fluendo-mpegdemux gconf gio gl gnomevfs hal \
- ladspa libpng mm mp3 musepack nas pulse python qt4 \
+ fluendo-mpegdemux gconf gio gnomevfs hal \
+ ladspa libpng mm mp3 musepack nas python qt4 \
sdl sndfile spc vdpau vp8 xvid
.endif
# plugins only in 1.0
.if defined(USE_GSTREAMER1)
_GSTREAMER_PLUGINS+= \
- assrender curl dvdread kate libav modplug openjpeg png rtmp \
+ assrender curl dvdread editing-services kate libav \
+ modplug openjpeg png rtmp \
spandsp vpx webp x ximagesrc zbar
# vaapi?
.endif
@@ -257,6 +258,11 @@ bz2_DEPENDS= multimedia/gstreamer-plugins-bz2
dvdread_DEPENDS= multimedia/gstreamer-plugins-dvdread
+editing-services_DEPENDS= multimedia/gstreamer-editing-services
+editing-services_GST_PREFIX= gstreamer1-
+editing-services_GST_SUFX= # empty
+editing-services_GST_VERSION= 1.0.0
+
ffmpeg_DEPENDS= multimedia/gstreamer-ffmpeg
ffmpeg_GST_PREFIX= gstreamer-
ffmpeg_GST_SUFX= # empty