aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gcc.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 4de739f0877d..72fe92ea9a60 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -189,11 +189,12 @@ CC:= gcc${V}
CXX:= g++${V}
CPP:= cpp${V}
. if ${_USE_GCC} != 3.4
-CFLAGS+= -Wl,-rpath=${LOCALBASE}/lib/gcc${V}
-LDFLAGS+= -Wl,-rpath=${LOCALBASE}/lib/gcc${V}
+_GCC_RUNTIME:= ${LOCALBASE}/lib/gcc${V}
+CFLAGS+= -Wl,-rpath=${_GCC_RUNTIME}
+LDFLAGS+= -Wl,-rpath=${_GCC_RUNTIME}
. if defined (USE_FORTRAN)
. if ${USE_FORTRAN} == yes
-FFLAGS+= -Wl,-rpath=${LOCALBASE}/lib/gcc${V}
+FFLAGS+= -Wl,-rpath=${_GCC_RUNTIME}
. endif
. endif
# The following is for the sakes of some ports which use this without