aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 417e5c03a73b..3fec1fc0cb71 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3154,6 +3154,7 @@ PACKAGE-DEPENDS-LIST= \
if (${ECHO} $$checked | ${GREP} -qwv "$$dir"); then \
childout=$$(cd $$dir; ${MAKE} CHILD_DEPENDS=yes PARENT_CHECKED="$$checked" package-depends-list); \
set -- $$childout; \
+ childname=""; childdir=""; \
while [ $$\# != 0 ]; do \
childname="$$childname $$1"; \
childdir="$$childdir $$2"; \