aboutsummaryrefslogtreecommitdiffstats
path: root/accessibility/orca
diff options
context:
space:
mode:
Diffstat (limited to 'accessibility/orca')
-rw-r--r--accessibility/orca/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/accessibility/orca/Makefile b/accessibility/orca/Makefile
index d817d3a7a600..eadbc07578d5 100644
--- a/accessibility/orca/Makefile
+++ b/accessibility/orca/Makefile
@@ -10,16 +10,16 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Scriptable screen reader
-BUILD_DEPENDS= py3?-dbus>=0:devel/py3-dbus \
- py3?-xdg>=0:devel/py3-xdg \
- py3?-cairo>=0:graphics/py3-cairo \
+BUILD_DEPENDS= py3?-dbus>=0:devel/py-dbus@${PY_FLAVOR} \
+ py3?-xdg>=0:devel/py-xdg@${PY_FLAVOR} \
+ py3?-cairo>=0:graphics/py-cairo@${PY_FLAVOR} \
itstool:textproc/itstool
LIB_DEPENDS= libatspi.so:accessibility/at-spi2-core
-RUN_DEPENDS= py3?-dbus>=0:devel/py3-dbus \
- py3?-speech-dispatcher>=0:accessibility/py3-speech-dispatcher \
- py3?-atspi>=0:accessibility/py3-atspi \
- py3?-xdg>=0:devel/py3-xdg \
- py3?-cairo>=0:graphics/py3-cairo
+RUN_DEPENDS= py3?-dbus>=0:devel/py-dbus@${PY_FLAVOR} \
+ py3?-speech-dispatcher>=0:accessibility/py-speech-dispatcher@${PY_FLAVOR} \
+ py3?-atspi>=0:accessibility/py-atspi@${PY_FLAVOR} \
+ py3?-xdg>=0:devel/py-xdg@${PY_FLAVOR} \
+ py3?-cairo>=0:graphics/py-cairo@${PY_FLAVOR}
# conflict with py*-json-py because orca uses the json from python itself
# and py*-json-py shadows this.
@@ -27,7 +27,7 @@ CONFLICTS= py*-json-py-[0-9]*
PORTSCOUT= limitw:1,even
NO_ARCH= yes
-USES= gettext gmake gnome pathfix pkgconfig python:3 tar:xz
+USES= gettext gmake gnome pathfix pkgconfig python:3.4+ tar:xz
USE_GNOME= gtk30 py3gobject3 intlhack
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes