aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/gcpio/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/gcpio/Makefile')
-rw-r--r--archivers/gcpio/Makefile19
1 files changed, 6 insertions, 13 deletions
diff --git a/archivers/gcpio/Makefile b/archivers/gcpio/Makefile
index 883104163ea4..bee82a17cdb1 100644
--- a/archivers/gcpio/Makefile
+++ b/archivers/gcpio/Makefile
@@ -11,7 +11,6 @@ PKGNAMEPREFIX= g
MAINTAINER= naddy@FreeBSD.org
COMMENT= GNU cpio copies files to and from archives
-NO_STAGE= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-prefix=g \
@@ -19,18 +18,12 @@ CONFIGURE_ARGS= --program-prefix=g \
--with-rmt=/etc/rmt
INFO= cpio
-MAN1= gcpio.1
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-CONFIGURE_ARGS+=--with-libintl-prefix="${LOCALBASE}"
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check