aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/hs-zlib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/hs-zlib/Makefile')
-rw-r--r--archivers/hs-zlib/Makefile63
1 files changed, 50 insertions, 13 deletions
diff --git a/archivers/hs-zlib/Makefile b/archivers/hs-zlib/Makefile
index bf362ee1ca35..8a86d048fb8d 100644
--- a/archivers/hs-zlib/Makefile
+++ b/archivers/hs-zlib/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= zlib
-PORTVERSION= 0.5.0.0
-PORTREVISION= 2
+PORTVERSION= 0.5.2.0
CATEGORIES= archivers haskell
MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/ \
http://kerneled.org/tmp/
@@ -16,23 +15,61 @@ MAINTAINER= haskell@FreeBSD.org
COMMENT= Pure Haskell interface to the C zlib library
BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc
-LIB_DEPENDS= gmp.8:${PORTSDIR}/math/libgmp4
+RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
-CABAL= ${LOCALBASE}/bin/runghc Setup.hs
-GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
-SUBDIR= lib/${PORTNAME}-${PORTVERSION}
-PLIST_SUB= GHC_VERSION="${GHC_VERSION}" \
- PORTVERSION=${PORTVERSION} \
- SUBDIR=${SUBDIR}
+GHC_VERSION= 6.10.4
+ZLIB_VERSION= ${PORTVERSION}
+
+GHC_CMD= ${LOCALBASE}/bin/ghc
+SETUP_CMD= ./setup
+
+DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
+ZLIB_LIBDIR_REL= lib/${DISTNAME}
+
+PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
+ ZLIB_VERSION=${ZLIB_VERSION} \
+ ZLIB_LIBDIR_REL=${ZLIB_LIBDIR_REL}
+
+.if defined(NOPORTDOCS)
+PLIST_SUB+= NOPORTDOCS=""
+.else
+PLIST_SUB+= NOPORTDOCS="@comment "
+.endif
+
+.if !defined(NOPORTDOCS)
+
+PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
+.if !empty(PORT_HADDOCK:M?0)
+BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
+.endif
+BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
+
+HSCOLOUR_VERSION= 1.13
+HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
+
+PORTDOCS= *
+.endif
+
+.SILENT:
do-configure:
- cd ${WRKSRC} && ${CABAL} configure --prefix=${PREFIX} --ghc
+ cd ${WRKSRC} && ${GHC_CMD} --make Setup.hs -o setup -package Cabal \
+ && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
do-build:
- cd ${WRKSRC} && ${CABAL} build && ${CABAL} register --gen-script
+ cd ${WRKSRC} && ${SETUP_CMD} build \
+ && ${SETUP_CMD} register --gen-script
+
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
+ --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
+.endif
do-install:
- cd ${WRKSRC} && ${CABAL} install
- ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${SUBDIR}/register.sh
+ cd ${WRKSRC} && ${SETUP_CMD} install \
+ && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${ZLIB_LIBDIR_REL}/register.sh
+
+post-install:
+ ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
.include <bsd.port.mk>