aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/linux-f10-upx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/linux-f10-upx/Makefile')
-rw-r--r--archivers/linux-f10-upx/Makefile22
1 files changed, 13 insertions, 9 deletions
diff --git a/archivers/linux-f10-upx/Makefile b/archivers/linux-f10-upx/Makefile
index e5abf413f4db..a681d2679b28 100644
--- a/archivers/linux-f10-upx/Makefile
+++ b/archivers/linux-f10-upx/Makefile
@@ -1,25 +1,29 @@
-# New ports collection makefile for: archivers/linux-upx
-# Date created: 03 Jun 2007
-# Whom: Boris Samorodov <bsam@FreeBSD.org>
+# New ports collection makefile for: archivers/linux-f8-upx
+# Date created: 2008-04-03
+# Whom: bsam
#
# $FreeBSD$
#
PORTNAME= upx
-PORTVERSION= 1.25
+PORTVERSION= 3.02
CATEGORIES= archivers linux
-MASTER_SITE_SUBDIR= ../extras/${LINUX_DIST_VER}/${LINUX_RPM_ARCH}
+PKGNAMEPREFIX= linux-f8-
DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
MAINTAINER= emulation@FreeBSD.org
-COMMENT= RPM of UPX, a high-performance executable packer
+COMMENT= UPX, a high-performance executable packer (Linux Fedora 8)
USE_LINUX_RPM= yes
USE_LINUX_APPS= ucl
-RPMVERSION= 4
-LINUX_DIST_VER= 4
+LINUX_DIST_VER= 8
+RPMVERSION= 1.fc8
BRANDELF_FILES= usr/bin/upx
-MASTER_SITE_SRC_SUBDIR= ../extras/${LINUX_DIST_VER}/SRPMS
+
+PLIST_FILES= usr/bin/upx usr/share/man/man1/upx.1.gz
+DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= BUGS COPYING LICENSE NEWS PROJECTS README README.1ST \
+ THANKS TODO elf-to-mem.txt filter.txt loader.txt selinux.txt
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
.include <bsd.port.mk>