aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/lz4/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/lz4/Makefile')
-rw-r--r--archivers/lz4/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/archivers/lz4/Makefile b/archivers/lz4/Makefile
new file mode 100644
index 000000000000..a5adb55bc974
--- /dev/null
+++ b/archivers/lz4/Makefile
@@ -0,0 +1,21 @@
+# Created by: Alexey Degtyarev <alexey@renatasystems.org>
+# $FreeBSD$
+
+PORTNAME= lz4
+PORTVERSION= r101
+CATEGORIES= archivers
+MASTER_SITES= https://dl.dropboxusercontent.com/u/59565338/LZ4/ \
+ ftp://ftp.renatasystems.org/pub/FreeBSD/ports/distfiles/
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= Fast compressor using LZ4 algorithm
+
+USES= gmake
+ALL_TARGET= lz4c
+
+PLIST_FILES= bin/lz4c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/lz4c.exe ${PREFIX}/bin/lz4c
+
+.include <bsd.port.mk>