aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/nomarch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/nomarch/Makefile')
-rw-r--r--archivers/nomarch/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/archivers/nomarch/Makefile b/archivers/nomarch/Makefile
index 2d9762eeafc7..0507b66e4368 100644
--- a/archivers/nomarch/Makefile
+++ b/archivers/nomarch/Makefile
@@ -12,17 +12,29 @@ CATEGORIES= archivers
MASTER_SITES= ${MASTER_SITE_SUNSITE}
MASTER_SITE_SUBDIR= utils/compress
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gkovesdan@t-hosting.hu
COMMENT= Extracts files from the old `.arc' archive format
USE_GETOPT_LONG=yes
-MAKE_ARGS= CC="${CC}" CFLAGS="${CPPFLAGS} ${CFLAGS} ${LDFLAGS}"
MAN1= nomarch.1
PLIST_FILES= bin/nomarch
+PORTDOCS= COPYING ChangeLog NEWS README TODO
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|CC=|CC?=|' \
+ -e 's|CFLAGS=|CFLAGS?=|' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/nomarch ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/nomarch.1 ${MAN1PREFIX}/man/man1
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
.include <bsd.port.mk>