aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/plzip/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/plzip/Makefile')
-rw-r--r--archivers/plzip/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/archivers/plzip/Makefile b/archivers/plzip/Makefile
new file mode 100644
index 000000000000..10e2c52f3c19
--- /dev/null
+++ b/archivers/plzip/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: plzip
+# Date created: 2010-05-22
+# Whom: Albert Vernon <f3cun3c02@sneakemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plzip
+PORTVERSION= 0.6
+CATEGORIES= archivers
+MASTER_SITES= SAVANNAH/lzip
+
+MAINTAINER= f3cun3c02@sneakemail.com
+COMMENT= Is a parallel, lossless data compressor based on the LZMA algorithm
+
+BUILD_DEPENDS= lzlib>=1.0:${PORTSDIR}/archivers/lzlib
+
+PLIST_FILES= bin/plzip
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= CXXFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+MAN1= plzip.1
+INFO= plzip
+.include <bsd.port.mk>
>2003-10-2815-1202/+1015 * utilize SITE_PERLijliao2003-10-241-6/+6 * Add a patch to properly escape generated action attribute intobez2003-09-302-1/+16 * Make portlint(1) happy by changing strip to ${STRIP_CMD}osa2003-09-241-1/+1 * Fix a bug which goes unnoticed on all platforms but leads to atobez2003-07-142-1/+32 * Respect global CC settings.sobomax2003-04-281-0/+1 * Under certain conditions, perl's configure script could pick a directorytobez2003-04-241-1/+2 * Patch Safe.pm (seetobez2003-04-212-1/+84 * Add a new `WITH_THREADS' option to build perl with support for threads andsobomax2003-04-012-2/+20 * Clear moonlight beckons.ade2003-03-072-1/+1 * chase gdbm lib versionijliao2003-01-031-1/+1 * Make port's Configure correctly detect crypt(3). Bump PORTREVISION.tobez2002-12-112-4/+16 * o Make perl -MConfig -e 'use lib $Config{installsitelib}' worktobez2002-08-212-1/+46 * Merge from lang/perl5:tobez2002-07-282-3/+24 * Modify BSDPAN to make INSTALLSITEMAN1DIR and INSTALLSITEMAN3DIR be equaltobez2002-07-232-2/+4 * Update to 5.8.0 (after repocopy).tobez2002-07-228-859/+1339 * 1. Merge from src/contrib/perl5/lib/ExtUtils/Attic/Install.pm rev. 1.2:tobez2002-07-113-6/+14 * During deinstallation, for *.ph files, replace find | xargs rm withtobez2002-06-161-1/+1 * Fix manpath.config patching in case there is no system perl manpathtobez2002-06-161-4/+11 * 1. Do not do rm -rf as a mean to deinstall this port. Instead, aparttobez2002-06-164-4/+123 * Bump PORTREVISION to take the new version of use.perl into account.dougb2002-06-091-1/+1 * Update to better handle life as it is now in -current.dougb2002-06-091-9/+26 * Put SITEARCH and SITELIB paths in front of ARCHLIB and PRIVLIB in thetobez2002-06-039-8/+87 * Use a cleaner, documented way to obtain the path of BSDPAN. This fixestobez2002-05-242-3/+4 * Make make depend to work with the new gcc (the new preprocessor outputstobez2002-05-211-0/+13 * 1. Speed up the fetch stage by using groups of MASTER_SITES.tobez2002-05-202-10/+11 * Unforbid the port for the use of general FreeBSD public.tobez2001-12-207-16/+142 * Make this port do the same thing whether databases/gdbm is installed ortobez2001-08-202-6/+3 * Fix wrong directory name.tobez2001-06-301-1/+1 * Take over maintainership.tobez2001-06-131-1/+1 * Update for Perl 5.6.1.markm2001-04-117-259/+349 * Upgrade this to perl5.6.0 for _knowledgeable_ folks in STABLE whomarkm2001-03-227-585/+873 * Some style fixes in the lang category (usual round of spaces -> tabs)olgeni2001-02-051-1/+1 * Correct the COMMENTcpiazza2000-05-191-1/+1 * ftp.cdrom.com -> ftp.freesoftware.com, adjusting paths as I go.billf2000-05-141-1/+1 * Typo (PORTVESION -> PORTVERSION).asami2000-04-141-1/+1 * Convert to the PORTNAME - PORTVERSION syntax.obrien2000-04-121-3/+3 * FreeBSD.ORG -> FreeBSD.orgmharo1999-08-311-1/+1 * ln -> ${LN}mharo1999-08-281-1/+1 * Change Id->FreeBSD.obrien1999-08-251-1/+1