aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/xarchiver/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/xarchiver/Makefile')
-rw-r--r--archivers/xarchiver/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/archivers/xarchiver/Makefile b/archivers/xarchiver/Makefile
index c63720235cff..bb0a1658f39f 100644
--- a/archivers/xarchiver/Makefile
+++ b/archivers/xarchiver/Makefile
@@ -22,20 +22,16 @@ GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
+NLS_USES= gettext
+NLS_CPPFLAGS+= -I${LOCALBASE}/include
+NLS_LDFLAGS+= -L${LOCALBASE}/lib
-.if !empty(PORT_OPTIONS:MNLS)
-USES+= gettext
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_SUB+= NLS=""
-.else
-PLIST_SUB+= NLS="@comment "
-.endif
+.include <bsd.port.options.mk>
post-patch:
-.if ! ${PORT_OPTIONS:MDOCS}
+.if empty(PORT_OPTIONS:MDOCS)
@${REINPLACE_CMD} -e 's|doc||g' ${WRKSRC}/Makefile.in
.endif
.if empty(PORT_OPTIONS:MNLS)