aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/xz/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'archivers/xz/Makefile')
-rw-r--r--archivers/xz/Makefile6
1 files changed, 1 insertions, 5 deletions
diff --git a/archivers/xz/Makefile b/archivers/xz/Makefile
index b6340bc8235a..35453e412795 100644
--- a/archivers/xz/Makefile
+++ b/archivers/xz/Makefile
@@ -18,9 +18,9 @@ COMMENT= LZMA compression and decompression tools
CONFLICTS= lzma-[0-9]* lzmautils-[0-9]* lzmalib-[0-9]*
MAKE_JOBS_SAFE= yes
-USE_AUTOTOOLS= autoheader:262 autoconf:262
USE_LDCONFIG= yes
USE_GNOME= gnomehack
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-dynamic=yes
CONFIGURE_ARGS+=--disable-nls # no translations available
@@ -46,10 +46,6 @@ MLINKS= xz.1 lzcat.1 xzdiff.1 lzcmp.1 \
PORTDOCS= AUTHORS COPYING COPYING.GPLv2 NEWS README THANKS TODO \
faq.txt history.txt lzma-file-format.txt xz-file-format.txt
-# no need to (attempt to) run aclocal
-pre-build:
- @touch -r ${WRKSRC}/configure.ac ${WRKSRC}/aclocal.m4
-
regression-test: build
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check