aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
Diffstat (limited to 'archivers')
-rw-r--r--archivers/libzip/Makefile17
-rw-r--r--archivers/libzip/distinfo6
-rw-r--r--archivers/libzip/pkg-descr11
-rw-r--r--archivers/libzip/pkg-plist9
4 files changed, 24 insertions, 19 deletions
diff --git a/archivers/libzip/Makefile b/archivers/libzip/Makefile
index 852ff0f80919..831e462603f0 100644
--- a/archivers/libzip/Makefile
+++ b/archivers/libzip/Makefile
@@ -6,28 +6,21 @@
#
PORTNAME= libzip
-PORTVERSION= 0.8
+PORTVERSION= 0.9.3
CATEGORIES= archivers devel
MASTER_SITES= http://www.nih.at/libzip/
MAINTAINER= makc@FreeBSD.org
COMMENT= A C library for reading, creating, and modifying zip archives
+USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GNOME= gnomehack pkgconfig
-PLIST_FILES= bin/zipcmp \
- bin/zipmerge \
- include/zip.h \
- lib/libzip.a \
- lib/libzip.la \
- lib/libzip.so \
- lib/libzip.so.1 \
- libdata/pkgconfig/libzip.pc
-
MAN1= zipcmp.1 \
- zipmerge.1
+ zipmerge.1 \
+ ziptorrent.1
MAN3= libzip.3 \
zip_add.3 \
@@ -47,6 +40,7 @@ MAN3= libzip.3 \
zip_fopen_index.3 \
zip_fread.3 \
zip_get_archive_comment.3 \
+ zip_get_archive_flag.3 \
zip_get_file_comment.3 \
zip_get_name.3 \
zip_get_num_files.3 \
@@ -55,6 +49,7 @@ MAN3= libzip.3 \
zip_rename.3 \
zip_replace.3 \
zip_set_archive_comment.3 \
+ zip_set_archive_flag.3 \
zip_set_file_comment.3 \
zip_source_buffer.3 \
zip_source_file.3 \
diff --git a/archivers/libzip/distinfo b/archivers/libzip/distinfo
index 117afa311e24..741a20ef2e0a 100644
--- a/archivers/libzip/distinfo
+++ b/archivers/libzip/distinfo
@@ -1,3 +1,3 @@
-MD5 (libzip-0.8.tar.gz) = b0087c2a12b312f8ec2df1052b2acb4f
-SHA256 (libzip-0.8.tar.gz) = 5a1b231d002b1a87ecab26874491ec6bea36b108f5f37769a2dc79b10623c047
-SIZE (libzip-0.8.tar.gz) = 414095
+MD5 (libzip-0.9.3.tar.bz2) = 27610091ca27bf843a6646cd05de35b9
+SHA256 (libzip-0.9.3.tar.bz2) = e63f5dc1b33fd1c02a881d5a819620634a69d1e4ce8637261ca0cb0fbc9f9dca
+SIZE (libzip-0.9.3.tar.bz2) = 304965
diff --git a/archivers/libzip/pkg-descr b/archivers/libzip/pkg-descr
index 6925f7b1c6e5..5409500d397b 100644
--- a/archivers/libzip/pkg-descr
+++ b/archivers/libzip/pkg-descr
@@ -1,6 +1,7 @@
-libzip is a C library for reading, creating, and modifying zip archives. Files
-can be added from data buffers, files, or compressed data copied directly from
-other zip archives. Changes made without closing the archive can be reverted.
-The API is documented by man pages.
+libzip is a C library for reading, creating, and modifying zip
+archives. Files can be added from data buffers, files, or compressed
+data copied directly from other zip archives. Changes made without
+closing the archive can be reverted. The API is documented by man
+pages.
-WWW: http://www.nih.at/libzip/
+WWW: http://www.nih.at/libzip/
diff --git a/archivers/libzip/pkg-plist b/archivers/libzip/pkg-plist
new file mode 100644
index 000000000000..7dc949ed9dbc
--- /dev/null
+++ b/archivers/libzip/pkg-plist
@@ -0,0 +1,9 @@
+bin/zipcmp
+bin/zipmerge
+bin/ziptorrent
+include/zip.h
+lib/libzip.a
+lib/libzip.la
+lib/libzip.so
+lib/libzip.so.1
+libdata/pkgconfig/libzip.pc