aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
Diffstat (limited to 'archivers')
-rw-r--r--archivers/arj/Makefile2
-rw-r--r--archivers/dpkg/Makefile2
-rw-r--r--archivers/libcomprex/Makefile3
-rw-r--r--archivers/libmspack/Makefile2
-rw-r--r--archivers/liborange/Makefile2
-rw-r--r--archivers/lzo/Makefile2
-rw-r--r--archivers/lzo2/Makefile2
-rw-r--r--archivers/orange/Makefile2
-rw-r--r--archivers/rpm/Makefile4
-rw-r--r--archivers/rpm4/Makefile2
-rw-r--r--archivers/rpm5/Makefile2
-rw-r--r--archivers/torrentzip/Makefile3
-rw-r--r--archivers/ucl/Makefile2
-rw-r--r--archivers/xpk/Makefile2
-rw-r--r--archivers/zipios++/Makefile3
15 files changed, 15 insertions, 20 deletions
diff --git a/archivers/arj/Makefile b/archivers/arj/Makefile
index cd4b04f01cd5..6eb35e114078 100644
--- a/archivers/arj/Makefile
+++ b/archivers/arj/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= garga@FreeBSD.org
COMMENT= Open-source ARJ
USE_REINPLACE= yes
-USE_AUTOCONF_VER= 259
+USE_AUTOTOOLS= autoconf:259
USE_GMAKE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_WRKSRC= ${WRKSRC}/gnu
diff --git a/archivers/dpkg/Makefile b/archivers/dpkg/Makefile
index 1ca3a1bce8ad..ce57eecf7c21 100644
--- a/archivers/dpkg/Makefile
+++ b/archivers/dpkg/Makefile
@@ -18,7 +18,7 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_ICONV= yes
USE_PERL5= yes
-USE_AUTOCONF_VER= 213
+USE_AUTOTOOLS= autoconf:213
WRKSRC= ${WRKDIR}/dpkg-${PORTVERSION}
CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
diff --git a/archivers/libcomprex/Makefile b/archivers/libcomprex/Makefile
index cbf7c44040b6..5dddc506d393 100644
--- a/archivers/libcomprex/Makefile
+++ b/archivers/libcomprex/Makefile
@@ -18,9 +18,8 @@ COMMENT= Transparently handles automatic compression and decompression of files
#LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
-USE_LIBLTDL= yes
+USE_AUTOTOOLS= libltdl:15 libtool:15
USE_GNOME= gnomehack gnometarget pkgconfig
-USE_LIBTOOL_VER= 15
LIBTOOLFLAGS= # none
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lintl"
diff --git a/archivers/libmspack/Makefile b/archivers/libmspack/Makefile
index b203005658eb..f40289b1cef8 100644
--- a/archivers/libmspack/Makefile
+++ b/archivers/libmspack/Makefile
@@ -17,7 +17,7 @@ COMMENT= A library for Microsoft compression formats
USE_REINPLACE= yes
USE_GETOPT_LONG= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
diff --git a/archivers/liborange/Makefile b/archivers/liborange/Makefile
index a962e9db4dcb..37075dc64aab 100644
--- a/archivers/liborange/Makefile
+++ b/archivers/liborange/Makefile
@@ -23,7 +23,7 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-libsynce=${LOCALBASE}
USE_ICONV= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
diff --git a/archivers/lzo/Makefile b/archivers/lzo/Makefile
index 8049f0627f80..42e40ebad857 100644
--- a/archivers/lzo/Makefile
+++ b/archivers/lzo/Makefile
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= libs/compression
MAINTAINER= matthias.andree@gmx.de
COMMENT= Portable speedy, lossless data compression library
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-shared
INSTALLS_SHLIB= yes
diff --git a/archivers/lzo2/Makefile b/archivers/lzo2/Makefile
index 631abc03be69..7d7e579f68ef 100644
--- a/archivers/lzo2/Makefile
+++ b/archivers/lzo2/Makefile
@@ -17,7 +17,7 @@ DISTNAME= lzo-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
MAINTAINER= matthias.andree@gmx.de
COMMENT= Portable speedy, lossless data compression library
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-shared
INSTALLS_SHLIB= yes
diff --git a/archivers/orange/Makefile b/archivers/orange/Makefile
index a962e9db4dcb..37075dc64aab 100644
--- a/archivers/orange/Makefile
+++ b/archivers/orange/Makefile
@@ -23,7 +23,7 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-libsynce=${LOCALBASE}
USE_ICONV= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
diff --git a/archivers/rpm/Makefile b/archivers/rpm/Makefile
index 588127042b2f..1ff7f17f06e1 100644
--- a/archivers/rpm/Makefile
+++ b/archivers/rpm/Makefile
@@ -20,10 +20,8 @@ CONFLICTS= rpm-4.*
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_AUTOMAKE_VER=14
-USE_AUTOCONF_VER=213
+USE_AUTOTOOLS= automake:14 autoconf:213 libtool:13:inc
USE_REINPLACE= yes
-USE_INC_LIBTOOL_VER= 13
CONFIGURE_ARGS= --with-glob
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl -liconv"
diff --git a/archivers/rpm4/Makefile b/archivers/rpm4/Makefile
index 3ea7ed492fa3..89bf9a688ba0 100644
--- a/archivers/rpm4/Makefile
+++ b/archivers/rpm4/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/gsed:${PORTSDIR}/textproc/gsed
BUILD_DEPENDS+= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
.endif
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
USE_GMAKE= yes
USE_GETTEXT= yes
USE_ICONV= yes
diff --git a/archivers/rpm5/Makefile b/archivers/rpm5/Makefile
index 3ea7ed492fa3..89bf9a688ba0 100644
--- a/archivers/rpm5/Makefile
+++ b/archivers/rpm5/Makefile
@@ -21,7 +21,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/gsed:${PORTSDIR}/textproc/gsed
BUILD_DEPENDS+= ${LOCALBASE}/bin/doxygen:${PORTSDIR}/devel/doxygen
.endif
-USE_LIBTOOL_VER=13
+USE_AUTOTOOLS= libtool:13
USE_GMAKE= yes
USE_GETTEXT= yes
USE_ICONV= yes
diff --git a/archivers/torrentzip/Makefile b/archivers/torrentzip/Makefile
index 8262f0ec7a29..8840a4a30037 100644
--- a/archivers/torrentzip/Makefile
+++ b/archivers/torrentzip/Makefile
@@ -16,9 +16,8 @@ DISTNAME= trrntzip_v${PORTVERSION:S/.//}_src
MAINTAINER= swhetzel@gmail.com
COMMENT= Efficient way to prepare zipfiles for BitTorrent
-USE_AUTOMAKE_VER= 19
+USE_AUTOTOOLS= automake:19 autoheader:259
AUTOMAKE_ARGS= -a
-USE_AUTOHEADER_VER= 259
WRKSRC= ${WRKDIR}/trrntzip
diff --git a/archivers/ucl/Makefile b/archivers/ucl/Makefile
index f3f1e07c73a5..86d87ec48e5e 100644
--- a/archivers/ucl/Makefile
+++ b/archivers/ucl/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A data compression library with low memory usage
INSTALLS_SHLIB= yes
-USE_LIBTOOL_VER= 15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --enable-shared
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/archivers/xpk/Makefile b/archivers/xpk/Makefile
index 816c5e4cfcc0..5cb48fe9e392 100644
--- a/archivers/xpk/Makefile
+++ b/archivers/xpk/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= http://www.jormas.com/~vesuri/xpk/ \
MAINTAINER= flynn@energyhq.es.eu.org
COMMENT= The eXternal PacKer (XPK) library system
-USE_INC_LIBTOOL_VER= 13
+USE_AUTOTOOLS= libtool:13:inc
INSTALLS_SHLIB= yes
.include <bsd.port.mk>
diff --git a/archivers/zipios++/Makefile b/archivers/zipios++/Makefile
index 1c32eba33284..0480cb631ade 100644
--- a/archivers/zipios++/Makefile
+++ b/archivers/zipios++/Makefile
@@ -20,10 +20,9 @@ GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
# port don't strictly need it, but Wesnoth use it so must we
USE_GCC= 3.4
-USE_INC_LIBTOOL_VER=15
+USE_AUTOTOOLS= automake:19:env libtool:15:inc
CONFIGURE_ARGS+=--disable-static
USE_REINPLACE= yes
-WANT_AUTOMAKE_VER=19
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}+cvs.2004.02.07