aboutsummaryrefslogtreecommitdiffstats
path: root/astro/boinc-setiathome-enhanced
diff options
context:
space:
mode:
Diffstat (limited to 'astro/boinc-setiathome-enhanced')
-rw-r--r--astro/boinc-setiathome-enhanced/Makefile12
-rw-r--r--astro/boinc-setiathome-enhanced/pkg-plist19
2 files changed, 18 insertions, 13 deletions
diff --git a/astro/boinc-setiathome-enhanced/Makefile b/astro/boinc-setiathome-enhanced/Makefile
index aeb4946cee53..ef7350de3aef 100644
--- a/astro/boinc-setiathome-enhanced/Makefile
+++ b/astro/boinc-setiathome-enhanced/Makefile
@@ -51,11 +51,15 @@ PLIST_SUB= SETI_BINARY="${SETI_BINARY}" SETI_SITE=${SETI_SITE} \
do-install:
${INSTALL} -d -o ${BOINC_USER} -g ${BOINC_GROUP} ${BOINC_HOME}/projects
- ${INSTALL} -d -o ${BOINC_USER} -g ${BOINC_GROUP} ${BOINC_HOME}/projects/${SETI_SITE}
- ${INSTALL_PROGRAM} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKDIR}/${SETI_BINARY} ${BOINC_HOME}/projects/${SETI_SITE}
-.for file in app_info.xml AUTHORS CHANGES COPYING COPYRIGHT README
- ${INSTALL_DATA} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKDIR}/${file} ${BOINC_HOME}/projects/${SETI_SITE}
+ ${INSTALL} -d -o ${BOINC_USER} -g ${BOINC_GROUP} ${BOINC_HOME}/projects/${SETI_SITE}$
+ ${INSTALL_PROGRAM} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKDIR}/${SETI_BINARY} ${BOINC_HOME}/projects/${SETI_SITE}/
+ ${INSTALL_DATA} -o ${BOINC_USER} -g ${BOINC_GROUP} ${WRKDIR}/app_info.xml ${BOINC_HOME}/projects/${SETI_SITE}/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in AUTHORS CHANGES COPYING COPYRIGHT README
+ ${INSTALL_DATA} ${WRKDIR}/${file} ${DOCSDIR}/${file}
.endfor
+.endif
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/astro/boinc-setiathome-enhanced/pkg-plist b/astro/boinc-setiathome-enhanced/pkg-plist
index 69857298c08e..da986802e005 100644
--- a/astro/boinc-setiathome-enhanced/pkg-plist
+++ b/astro/boinc-setiathome-enhanced/pkg-plist
@@ -1,9 +1,10 @@
-@cwd %%BOINC_HOME%%
-projects/%%SETI_SITE%%/app_info.xml
-projects/%%SETI_SITE%%/AUTHORS
-projects/%%SETI_SITE%%/CHANGES
-projects/%%SETI_SITE%%/COPYING
-projects/%%SETI_SITE%%/COPYRIGHT
-projects/%%SETI_SITE%%/README
-projects/%%SETI_SITE%%/%%SETI_BINARY%%
-@dirrmtry %D/projects/%%SETI_SITE%% 2>/dev/null
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@cwd %%BOINC_HOME%%/projects
+%%SETI_SITE%%/app_info.xml
+%%SETI_SITE%%/%%SETI_BINARY%%
+@dirrmtry %%SETI_SITE%%