aboutsummaryrefslogtreecommitdiffstats
path: root/astro/celestia/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/celestia/Makefile')
-rw-r--r--astro/celestia/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index fa02090777c6..5bc2b62f78f3 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -19,12 +19,6 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
gtkgl.5:${PORTSDIR}/x11-toolkits/gtkglarea
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile (bad C++ code)"
-.endif
-
GNU_CONFIGURE= yes
PLIST= ${WRKDIR}/pkg-plist
USE_GMAKE= yes
@@ -39,6 +33,12 @@ CONFIGURE_ENV= \
LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib -lm ${PTHREAD_LIBS}"
CPPFLAGS="-I${X11BASE}/include -I${X11BASE}/include/GL -I${LOCALBASE}/include ${PTHREAD_CFLAGS}"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile (bad C++ code)"
+.endif
+
pre-patch:
${PERL} -pi -e \
"s:-O2::g; s:-Wall::g; s:-ffast-math::g; s:-fexpensive-optimizations::g; s:\!\ /bin/sh:\!\ ${LOCALBASE}/bin/bash:g" \