aboutsummaryrefslogtreecommitdiffstats
path: root/astro/ksetisaver/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/ksetisaver/Makefile')
-rw-r--r--astro/ksetisaver/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/astro/ksetisaver/Makefile b/astro/ksetisaver/Makefile
new file mode 100644
index 000000000000..af9ac4e75da2
--- /dev/null
+++ b/astro/ksetisaver/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: ksetisaver
+# Date created: 18 January 2003
+# Whom: Scott A. Moberly <smoberly@karamazov.org>
+#
+# $FreeBSD$
+
+PORTNAME= ksetisaver
+PORTVERSION= 0.3.4
+CATEGORIES= astro kde
+MASTER_SITES= http://www.frozenlight.de/content/ksetisaver/
+
+MAINTAINER= smoberly@karamazov.org
+COMMENT= A KDE screensaver frontend for the Linux seti@home client
+
+USE_KDELIBS_VER=3
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_REINPLACE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,/opt/seti,/var/db/setiathome," \
+ ${WRKSRC}/ksetisaver/configdialogR2.cpp \
+ ${WRKSRC}/ksetisaver/configdialogR2.ui \
+ ${WRKSRC}/ksetisaver/configuration.cpp \
+ ${WRKSRC}/po/de.po \
+ ${WRKSRC}/po/fr.po \
+ ${WRKSRC}/po/zh_CN.GB2312.po \
+ ${WRKSRC}/po/ksetisaver.pot
+
+.include <bsd.port.mk>