aboutsummaryrefslogtreecommitdiffstats
path: root/astro/kstars
diff options
context:
space:
mode:
Diffstat (limited to 'astro/kstars')
-rw-r--r--astro/kstars/Makefile10
-rw-r--r--astro/kstars/distinfo4
-rw-r--r--astro/kstars/files/patch-kstars__skyobjects__kscomet.cpp11
-rw-r--r--astro/kstars/pkg-descr2
-rw-r--r--astro/kstars/pkg-plist20
5 files changed, 22 insertions, 25 deletions
diff --git a/astro/kstars/Makefile b/astro/kstars/Makefile
index 76670aff423b..e514832dda0f 100644
--- a/astro/kstars/Makefile
+++ b/astro/kstars/Makefile
@@ -2,7 +2,6 @@
PORTNAME= kstars
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 3
CATEGORIES= astro kde
MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
@@ -12,12 +11,17 @@ COMMENT= KDE 4 desktop planetarium
LIB_DEPENDS= libcfitsio.so:${PORTSDIR}/astro/cfitsio \
libwcs.so:${PORTSDIR}/astro/wcslib
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2 \
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen3.pc:${PORTSDIR}/math/eigen3 \
xplanet:${PORTSDIR}/astro/xplanet
RUN_DEPENDS= xplanet:${PORTSDIR}/astro/xplanet
-USE_KDE4= kdehier kdelibs kdeprefix automoc4
+USE_KDE4= kdelibs kdeprefix automoc4
USES= cmake:outsource compiler:c++11-lib tar:xz
USE_QT4= opengl qmake_build moc_build rcc_build uic_build
+OPTIONS_DEFINE= PYKDE
+
+PYKDE_DESC= Support for updating supernovae data
+PYKDE_USE= KDE4=pykde4_run
+
.include <bsd.port.mk>
diff --git a/astro/kstars/distinfo b/astro/kstars/distinfo
index 3d4b185032eb..b4c2b28d7719 100644
--- a/astro/kstars/distinfo
+++ b/astro/kstars/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.12.5/kstars-4.12.5.tar.xz) = b22676f0f875e759c402b07af373e446bdebfc73b3d766cbcfdfe5265b6bae05
-SIZE (KDE/4.12.5/kstars-4.12.5.tar.xz) = 12344692
+SHA256 (KDE/4.14.2/kstars-4.14.2.tar.xz) = fa43988f0d20c2884a931e55cc9acaa09bc15ab78ebe84e3f478f3093b33320c
+SIZE (KDE/4.14.2/kstars-4.14.2.tar.xz) = 12374032
diff --git a/astro/kstars/files/patch-kstars__skyobjects__kscomet.cpp b/astro/kstars/files/patch-kstars__skyobjects__kscomet.cpp
new file mode 100644
index 000000000000..9b06ba84006e
--- /dev/null
+++ b/astro/kstars/files/patch-kstars__skyobjects__kscomet.cpp
@@ -0,0 +1,11 @@
+--- kstars/skyobjects/kscomet.cpp.orig 2014-09-15 23:02:14.160209962 +0200
++++ kstars/skyobjects/kscomet.cpp 2014-09-15 23:03:33.261204279 +0200
+@@ -119,7 +119,7 @@
+ qint64 fragment = letterDesigToN( rePro.cap(6) );
+
+ uidPart =
+- 1 << 43 |
++ 1ull << 43 |
+ type << 40 | // Bits 40-42 (3)
+ halfMonth << 33 | // Bits 33-39 (7) Hope this is enough
+ nHalfMonth << 28 | // Bits 28-32 (5)
diff --git a/astro/kstars/pkg-descr b/astro/kstars/pkg-descr
index da47f58db6b9..0e4116d41f71 100644
--- a/astro/kstars/pkg-descr
+++ b/astro/kstars/pkg-descr
@@ -4,4 +4,4 @@ any date and time. The display includes up to 100 million stars,
13,000 deep-sky objects, all 8 planets, the Sun and Moon, and
thousands of comets and asteroids.
-WWW: http://edu.kde.org/kstars
+WWW: http://edu.kde.org/kstars
diff --git a/astro/kstars/pkg-plist b/astro/kstars/pkg-plist
index 4e9c584cc8df..6a5fbbdfe45e 100644
--- a/astro/kstars/pkg-plist
+++ b/astro/kstars/pkg-plist
@@ -1,5 +1,6 @@
bin/kstars
lib/libhtmesh.a
+share/appdata/kstars.appdata.xml
share/applications/kde4/kstars.desktop
share/apps/kstars/Cities.dat
share/apps/kstars/Interesting.dat
@@ -456,22 +457,3 @@ share/icons/hicolor/32x32/apps/kstars.png
share/icons/hicolor/48x48/apps/kstars.png
share/icons/hicolor/64x64/apps/kstars.png
share/icons/hicolor/scalable/apps/kstars.svgz
-@dirrm share/doc/HTML/en/kstars
-@dirrm share/apps/kstars/tools/whatsinteresting/qml
-@dirrm share/apps/kstars/tools/whatsinteresting
-@dirrm share/apps/kstars/tools
-@dirrm share/apps/kstars/textures
-@dirrm share/apps/kstars/scripts
-@dirrm share/apps/kstars/icons/hicolor/scalable/actions
-@dirrm share/apps/kstars/icons/hicolor/scalable
-@dirrm share/apps/kstars/icons/hicolor/64x64/actions
-@dirrm share/apps/kstars/icons/hicolor/64x64
-@dirrm share/apps/kstars/icons/hicolor/48x48/actions
-@dirrm share/apps/kstars/icons/hicolor/48x48
-@dirrm share/apps/kstars/icons/hicolor/32x32/actions
-@dirrm share/apps/kstars/icons/hicolor/32x32
-@dirrm share/apps/kstars/icons/hicolor/22x22/actions
-@dirrm share/apps/kstars/icons/hicolor/22x22
-@dirrm share/apps/kstars/icons/hicolor
-@dirrm share/apps/kstars/icons
-@dirrm share/apps/kstars