aboutsummaryrefslogtreecommitdiffstats
path: root/astro/p5-Astro-Sunrise/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/p5-Astro-Sunrise/Makefile')
-rw-r--r--astro/p5-Astro-Sunrise/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/astro/p5-Astro-Sunrise/Makefile b/astro/p5-Astro-Sunrise/Makefile
index b04f816146ec..7ac8697a817a 100644
--- a/astro/p5-Astro-Sunrise/Makefile
+++ b/astro/p5-Astro-Sunrise/Makefile
@@ -6,17 +6,23 @@
#
PORTNAME= Astro-Sunrise
-PORTVERSION= 0.05
+PORTVERSION= 0.8
CATEGORIES= astro perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Astro
PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
+COMMENT= Perl extension for computing the sunrise/sunset on a given day
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/Piece.pm:${PORTSDIR}/devel/p5-Time-Piece
PERL_CONFIGURE= yes
MAN3= Astro::Sunrise.3
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-patch:
+ ${PERL} -pi -e 's/(qw\(.*)\[1\];/($$1)[1];/' \
+ ${WRKSRC}/Sunrise.pm
.include <bsd.port.mk>