aboutsummaryrefslogtreecommitdiffstats
path: root/astro/p5-Starlink-AST/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/p5-Starlink-AST/Makefile')
-rw-r--r--astro/p5-Starlink-AST/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/astro/p5-Starlink-AST/Makefile b/astro/p5-Starlink-AST/Makefile
index fa816949b3d6..d853ff20f6d0 100644
--- a/astro/p5-Starlink-AST/Makefile
+++ b/astro/p5-Starlink-AST/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= Starlink-AST
-PORTVERSION= 1.02
+PORTVERSION= 1.04
CATEGORIES= astro perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:TJENNESS
@@ -11,10 +11,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Interface to the Starlink AST library
-BUILD_DEPENDS= p5-Test-Number-Delta>=0:${PORTSDIR}/devel/p5-Test-Number-Delta
-RUN_DEPENDS= p5-Test-Number-Delta>=0:${PORTSDIR}/devel/p5-Test-Number-Delta
+BUILD_DEPENDS= p5-Test-Number-Delta>=0:${PORTSDIR}/devel/p5-Test-Number-Delta \
+ p5-Astro-FITS-CFITSIO>=0:${PORTSDIR}/astro/p5-Astro-FITS-CFITSIO \
+ p5-Astro-FITS-Header>=0:${PORTSDIR}/astro/p5-Astro-FITS-Header
+RUN_DEPENDS= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= modbuild
+post-stage:
+ ${STRIP_CMD} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Starlink/AST/AST.so
+ ${RM} ${STAGEDIR}${SITE_PERL}/${PERL_ARCH}/auto/Starlink/AST/AST.bs
+
.include <bsd.port.mk>