aboutsummaryrefslogtreecommitdiffstats
path: root/astro/p5-Weather-Underground/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/p5-Weather-Underground/Makefile')
-rw-r--r--astro/p5-Weather-Underground/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/astro/p5-Weather-Underground/Makefile b/astro/p5-Weather-Underground/Makefile
new file mode 100644
index 000000000000..380a6b80a24e
--- /dev/null
+++ b/astro/p5-Weather-Underground/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Weather-Underground
+# Date created: 2006-05-16
+# Whom: Simon Olofsson <simon@olofsson.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Weather-Underground
+PORTVERSION= 3.02
+CATEGORIES= astro perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Weather
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= simon@olofsson.de
+COMMENT= Retrieve weather information from wunderground.com
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/Simple.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/TokeParser.pm:${PORTSDIR}/www/p5-HTML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Weather::Underground.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>