aboutsummaryrefslogtreecommitdiffstats
path: root/astro/position/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/position/Makefile')
-rw-r--r--astro/position/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/astro/position/Makefile b/astro/position/Makefile
index 72759337bf12..8a5bd60f2346 100644
--- a/astro/position/Makefile
+++ b/astro/position/Makefile
@@ -14,22 +14,18 @@ MAINTAINER= dinoex@FreeBSD.org
COMMENT= GPS and Moving-Map Applikation
BUILD_DEPENDS= ${LOCALBASE}/lib/libproj.a:${PORTSDIR}/${PROJ4_PORT}
+RUN_DEPENDS= ${LOCALBASE}/lib/libproj.a:${PORTSDIR}/${PROJ4_PORT}
-WRKSRC= ${WRKDIR}/Position
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE= GNUmakefile
-USE_GNUSTEP_MAKE_DIRS+= Position
-
-PROJ4_PORT?= misc/proj4
+WRKSRC= ${WRKDIR}/Position/Position
ADDITIONAL_OBJCFLAGS+= -I${LOCALBASE}/include
ADDITIONAL_LDFLAGS+= -L${LOCALBASE}/lib
-MAKE_ENV+= ADDITIONAL_OBJCFLAGS="${ADDITIONAL_OBJCFLAGS}"
-MAKE_ENV+= ADDITIONAL_LDFLAGS="${ADDITIONAL_LDFLAGS}"
+
+PROJ4_PORT?= misc/proj4
.include <bsd.port.mk>