aboutsummaryrefslogtreecommitdiffstats
path: root/astro/spacechart
diff options
context:
space:
mode:
Diffstat (limited to 'astro/spacechart')
-rw-r--r--astro/spacechart/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/astro/spacechart/Makefile b/astro/spacechart/Makefile
index 540fbb467fa2..0180c5048c62 100644
--- a/astro/spacechart/Makefile
+++ b/astro/spacechart/Makefile
@@ -18,13 +18,14 @@ COMMENT= SpaceChart is a star chart viewer for GNOME
LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
USE_X_PREFIX= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomelibs
CONFIGURE_ARGS= --without-included-gettext --datadir=${PREFIX}/share
# trick it into using ports installed gettext
post-patch:
- @${PERL} -pi -ne "s|(INTLLIBS =).*$$|\1-I${LOCALBASE}/lib -lintl|" \
+ @${REINPLACE_CMD} -e 's|\(INTLLIBS =\).*$$|\1-I${LOCALBASE}/lib -lintl|' \
${WRKSRC}/src/Makefile.in
pre-build: