aboutsummaryrefslogtreecommitdiffstats
path: root/astro/wcslib
diff options
context:
space:
mode:
Diffstat (limited to 'astro/wcslib')
-rw-r--r--astro/wcslib/Makefile43
-rw-r--r--astro/wcslib/distinfo3
-rw-r--r--astro/wcslib/pkg-descr7
-rw-r--r--astro/wcslib/pkg-plist46
4 files changed, 99 insertions, 0 deletions
diff --git a/astro/wcslib/Makefile b/astro/wcslib/Makefile
new file mode 100644
index 000000000000..d2ea26f477ad
--- /dev/null
+++ b/astro/wcslib/Makefile
@@ -0,0 +1,43 @@
+# ex:ts=4
+# New ports collection makefile for: wcslib
+# Date created: Wed Jul 15 10:09:45 EST 2009
+# Whom: Tony Maher <tonymaher@optusnet.com.au>
+#
+# $FreeBSD$
+
+PORTNAME= wcslib
+PORTVERSION= 4.3.3
+CATEGORIES= astro
+MASTER_SITES= ftp://ftp.atnf.csiro.au/pub/software/wcslib/
+
+MAINTAINER= tonymaher@optusnet.com.au
+COMMENT= Library for parsing/generating FITS headers
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+USE_LDCONFIG= yes
+
+# See makedefs.in which describes why you want to set the extra support.
+# For most users it will not be required.
+
+OPTIONS= CFITSIO "Add cfitsio support (for tests only)" Off \
+ PGPLOT "Add pgplot support (for tests only)" Off
+
+.include <bsd.port.pre.mk>
+
+# The configure script unconditionally searches for the cftisio library
+# and uses it if found.
+
+.if defined(WITH_CFITSIO) || exists(${LOCALBASE}/lib/libcfitsio.so)
+PLIST_SUB+= HPXCVT=""
+LIB_DEPENDS+= cfitsio:${PORTSDIR}/astro/cfitsio
+.else
+PLIST_SUB+= HPXCVT="@comment "
+.endif
+
+.if defined(WITH_PGPLOT)
+LIB_DEPENDS+= pgplot.5:${PORTSDIR}/graphics/pgplot
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/astro/wcslib/distinfo b/astro/wcslib/distinfo
new file mode 100644
index 000000000000..ec019bcdd271
--- /dev/null
+++ b/astro/wcslib/distinfo
@@ -0,0 +1,3 @@
+MD5 (wcslib-4.3.3.tar.gz) = 651b9e7a1845919fdad20f833aaac0bc
+SHA256 (wcslib-4.3.3.tar.gz) = 24031144861085dc1e45cf0c2f3864eb40f259a65ab80a2ce547fd1baabc02de
+SIZE (wcslib-4.3.3.tar.gz) = 629037
diff --git a/astro/wcslib/pkg-descr b/astro/wcslib/pkg-descr
new file mode 100644
index 000000000000..76490bb1ad26
--- /dev/null
+++ b/astro/wcslib/pkg-descr
@@ -0,0 +1,7 @@
+"WCSLIB is a C library, supplied with a full set of Fortran wrappers, that
+ implements the "World Coordinate System" (WCS) convention in FITS (Flexible
+ Image Transport System). It also includes a PGPLOT-based routine, PGSBOX,
+ for drawing general curvilinear coordinate graticules and a number of
+ utility programs." - from README file.
+
+WWW: http://www.atnf.csiro.au/people/mcalabre/WCS/index.html
diff --git a/astro/wcslib/pkg-plist b/astro/wcslib/pkg-plist
new file mode 100644
index 000000000000..79cef6a08e10
--- /dev/null
+++ b/astro/wcslib/pkg-plist
@@ -0,0 +1,46 @@
+%%HPXCVT%%bin/HPXcvt
+bin/fitshdr
+include/wcslib
+include/wcslib-4.3/CHANGES_C
+include/wcslib-4.3/CHANGES_FORTRAN
+include/wcslib-4.3/COPYING
+include/wcslib-4.3/README
+include/wcslib-4.3/cel.h
+include/wcslib-4.3/cel.inc
+include/wcslib-4.3/fitshdr.h
+include/wcslib-4.3/fitshdr.inc
+include/wcslib-4.3/getwcstab.h
+include/wcslib-4.3/getwcstab.inc
+include/wcslib-4.3/lin.h
+include/wcslib-4.3/lin.inc
+include/wcslib-4.3/log.h
+include/wcslib-4.3/log.inc
+include/wcslib-4.3/prj.h
+include/wcslib-4.3/prj.inc
+include/wcslib-4.3/spc.h
+include/wcslib-4.3/spc.inc
+include/wcslib-4.3/sph.h
+include/wcslib-4.3/sph.inc
+include/wcslib-4.3/spx.h
+include/wcslib-4.3/spx.inc
+include/wcslib-4.3/tab.h
+include/wcslib-4.3/tab.inc
+include/wcslib-4.3/wcs.h
+include/wcslib-4.3/wcs.inc
+include/wcslib-4.3/wcsconfig.h
+include/wcslib-4.3/wcsconfig_f77.h
+include/wcslib-4.3/wcsfix.h
+include/wcslib-4.3/wcsfix.inc
+include/wcslib-4.3/wcshdr.h
+include/wcslib-4.3/wcshdr.inc
+include/wcslib-4.3/wcslib.h
+include/wcslib-4.3/wcsmath.h
+include/wcslib-4.3/wcstrig.h
+include/wcslib-4.3/wcsunits.h
+include/wcslib-4.3/wcsunits.inc
+include/wcslib-4.3/wcsutil.h
+lib/libwcs-4.3.a
+lib/libwcs.a
+lib/libwcs.so
+lib/libwcs.so.4.3
+@dirrm include/wcslib-4.3