aboutsummaryrefslogtreecommitdiffstats
path: root/astro/weather
diff options
context:
space:
mode:
Diffstat (limited to 'astro/weather')
-rw-r--r--astro/weather/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/astro/weather/Makefile b/astro/weather/Makefile
index abe043e1e0f9..9c8353d78ee1 100644
--- a/astro/weather/Makefile
+++ b/astro/weather/Makefile
@@ -13,8 +13,7 @@ COMMENT= Utility to provide current weather conditions and forecasts
LICENSE= ISCL
-USE_PYTHON= yes
-USES= shebangfix tar:xz
+USES= python shebangfix tar:xz
PLIST_FILES= bin/${PORTNAME} \
%%PYTHON_SITELIBDIR%%/${PORTNAME}.py \
@@ -32,6 +31,7 @@ python_CMD= ${PYTHON_CMD}
PYCACHE_DIR= # empty
PYCACHE_FILE= ${PORTNAME}
.else
+PLIST_DIRS= %%PYTHON_SITELIBDIR%%/__pycache__
PYCACHE_DIR= __pycache__/
PYCACHE_FILE= ${PORTNAME}.cpython-${PYTHON_SUFFIX}
.endif