aboutsummaryrefslogtreecommitdiffstats
path: root/astro/weatherget/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/weatherget/Makefile')
-rw-r--r--astro/weatherget/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/astro/weatherget/Makefile b/astro/weatherget/Makefile
new file mode 100644
index 000000000000..8252e43c7b08
--- /dev/null
+++ b/astro/weatherget/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: weatherget
+# Date created: 31 January 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= weatherget
+PORTVERSION= 0.3
+CATEGORIES= astro
+MASTER_SITES= BERLIOS
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Command-line weather reporting tool
+
+USE_BZIP2= yes
+USE_PYTHON= yes
+#USE_PYDISTUTILS=yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PORTDOCS= AUTHORS CHANGELOG README
+PLIST_FILES= bin/${PORTNAME}
+MAN1= ${PORTNAME}.1
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^#!/s|!.*|!${PYTHON_CMD}|' ${WRKSRC}/${PORTNAME}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1/
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>