aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/p5-ZConf-Weather/Makefile26
-rw-r--r--astro/p5-ZConf-Weather/distinfo3
-rw-r--r--astro/p5-ZConf-Weather/pkg-descr6
-rw-r--r--astro/p5-ZConf-Weather/pkg-plist8
5 files changed, 44 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index d3d4f6f852a5..9fef5bbbaf23 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -59,6 +59,7 @@
SUBDIR += p5-GPS-Babel
SUBDIR += p5-Geo-METAR
SUBDIR += p5-Weather-Underground
+ SUBDIR += p5-ZConf-Weather
SUBDIR += phoon
SUBDIR += planets
SUBDIR += position
diff --git a/astro/p5-ZConf-Weather/Makefile b/astro/p5-ZConf-Weather/Makefile
new file mode 100644
index 000000000000..f0d09c31760c
--- /dev/null
+++ b/astro/p5-ZConf-Weather/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-ZConf-Weather
+# Date created: 2009-09-27
+# Whom: Zane C, Bowers <vvelox@vvelox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ZConf-Weather
+PORTVERSION= 0.1.1
+CATEGORIES= astro perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/V/VV/VVELOX
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= A ZConf module to assist with fetching/printing weather information
+
+BUILD_DEPENDS= ${SITE_PERL}/ZConf.pm:${PORTSDIR}/net/p5-ZConf \
+ ${SITE_PERL}/Text/NeatTemplate.pm:${PORTSDIR}/textproc/p5-Text-NeatTemplate \
+ ${SITE_PERL}/Weather/Underground.pm:${PORTSDIR}/astro/p5-Weather-Underground
+
+PERL_CONFIGURE= yes
+
+MAN3= ZConf::Weather.3
+
+.include <bsd.port.mk>
diff --git a/astro/p5-ZConf-Weather/distinfo b/astro/p5-ZConf-Weather/distinfo
new file mode 100644
index 000000000000..ab908358f3b7
--- /dev/null
+++ b/astro/p5-ZConf-Weather/distinfo
@@ -0,0 +1,3 @@
+MD5 (ZConf-Weather-0.1.1.tar.gz) = bc7849265569b202e9fc996c1ca7609c
+SHA256 (ZConf-Weather-0.1.1.tar.gz) = 7ea286603c2488aeaee406fa953635f0f4660773499fbb318a7834fe63214d7c
+SIZE (ZConf-Weather-0.1.1.tar.gz) = 8401
diff --git a/astro/p5-ZConf-Weather/pkg-descr b/astro/p5-ZConf-Weather/pkg-descr
new file mode 100644
index 000000000000..01ddf11487df
--- /dev/null
+++ b/astro/p5-ZConf-Weather/pkg-descr
@@ -0,0 +1,6 @@
+A ZConf based library to facilitate fetching weather information
+and dumping it or printing it via a template.
+
+zcweather - Fetches the weather for the specified location.
+
+WWW: http://search.cpan.org/dist/ZConf-Weather
diff --git a/astro/p5-ZConf-Weather/pkg-plist b/astro/p5-ZConf-Weather/pkg-plist
new file mode 100644
index 000000000000..d3cd861ae82a
--- /dev/null
+++ b/astro/p5-ZConf-Weather/pkg-plist
@@ -0,0 +1,8 @@
+bin/zcweather
+%%SITE_PERL%%/ZConf/Weather.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/ZConf/Weather/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ZConf/Weather
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/ZConf
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%
+@dirrmtry %%SITE_PERL%%/ZConf