aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
Diffstat (limited to 'astro')
-rw-r--r--astro/astrometry/Makefile8
-rw-r--r--astro/celestia/Makefile6
-rw-r--r--astro/foxtrotgps/Makefile8
-rw-r--r--astro/glunarclock/Makefile2
-rw-r--r--astro/gpsbabel/Makefile2
-rw-r--r--astro/gpscorrelate/Makefile4
-rw-r--r--astro/mymoon/Makefile2
-rw-r--r--astro/nightfall/Makefile4
-rw-r--r--astro/openuniverse/Makefile2
-rw-r--r--astro/p5-Astro-FITS-CFITSIO/Makefile2
-rw-r--r--astro/rmap/Makefile2
-rw-r--r--astro/roadmap/Makefile2
-rw-r--r--astro/sunclock/Makefile4
-rw-r--r--astro/wcslib/Makefile4
-rw-r--r--astro/wmglobe/Makefile2
-rw-r--r--astro/xephem/Makefile4
-rw-r--r--astro/xmoontool/Makefile2
-rw-r--r--astro/xplanet/Makefile12
-rw-r--r--astro/xtide/Makefile3
19 files changed, 37 insertions, 38 deletions
diff --git a/astro/astrometry/Makefile b/astro/astrometry/Makefile
index 06b3d68a2657..f4b16c72094b 100644
--- a/astro/astrometry/Makefile
+++ b/astro/astrometry/Makefile
@@ -11,10 +11,10 @@ DISTNAME= astrometry.net-${PORTVERSION}
MAINTAINER= dereckson@gmail.com
COMMENT= Describes an astronomical image
-LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- netpbm.1:${PORTSDIR}/graphics/netpbm
+LIB_DEPENDS= libcairo.so:${PORTSDIR}/graphics/cairo \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libnetpbm.so:${PORTSDIR}/graphics/netpbm
BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
diff --git a/astro/celestia/Makefile b/astro/celestia/Makefile
index a4fb0f823ee6..c973cc0d5c3f 100644
--- a/astro/celestia/Makefile
+++ b/astro/celestia/Makefile
@@ -13,8 +13,8 @@ COMMENT= Scriptable space flight simulator for X11
LICENSE= GPLv2
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png
NO_STAGE= yes
USES= gettext gmake pkgconfig
@@ -59,7 +59,7 @@ IGNORE= requires one of the <${UI_LIST}> values for CELESTIA_UI
.if ${CELESTIA_UI} == "gtk" || ${CELESTIA_UI} == "gnome"
USE_GNOME+= gnomehack
-LIB_DEPENDS+= gtkglext-x11-1:${PORTSDIR}/x11-toolkits/gtkglext \
+LIB_DEPENDS+= libgtkglext-x11-1.so:${PORTSDIR}/x11-toolkits/gtkglext \
theora:${PORTSDIR}/multimedia/libtheora
STARTUP_NOTIFY= true
PLIST_FILES+= share/celestia/celestia-logo.png share/celestia/celestiaui.xml
diff --git a/astro/foxtrotgps/Makefile b/astro/foxtrotgps/Makefile
index ed758405d0e0..c8724b35ac19 100644
--- a/astro/foxtrotgps/Makefile
+++ b/astro/foxtrotgps/Makefile
@@ -10,10 +10,10 @@ MASTER_SITES= http://www.foxtrotgps.org/releases/
MAINTAINER= crwhipp@gmail.com
COMMENT= Lightweight opensource gps moving map application
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- exif:${PORTSDIR}/graphics/libexif \
- soup-2.4:${PORTSDIR}/devel/libsoup \
- gps:${PORTSDIR}/astro/gpsd
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libexif.so:${PORTSDIR}/graphics/libexif \
+ libsoup-2.so:${PORTSDIR}/devel/libsoup \
+ libgps.so:${PORTSDIR}/astro/gpsd
GNU_CONFIGURE= yes
NO_STAGE= yes
diff --git a/astro/glunarclock/Makefile b/astro/glunarclock/Makefile
index 5499cf2003a6..01a08aa22fb7 100644
--- a/astro/glunarclock/Makefile
+++ b/astro/glunarclock/Makefile
@@ -11,7 +11,7 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= GNOME applet that displays the current phase of the Moon
-LIB_DEPENDS= xklavier.12:${PORTSDIR}/x11/libxklavier
+LIB_DEPENDS= libxklavier.so:${PORTSDIR}/x11/libxklavier
NO_STAGE= yes
USES= pathfix gettext gmake pkgconfig
diff --git a/astro/gpsbabel/Makefile b/astro/gpsbabel/Makefile
index b3e2eea68e97..92eea99683b1 100644
--- a/astro/gpsbabel/Makefile
+++ b/astro/gpsbabel/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= https://secure.ohos.nl/downloads/ \
MAINTAINER= dev2@heesakkers.info
COMMENT= GPS file translating tool
-LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
NO_STAGE= yes
USE_AUTOTOOLS= autoconf
diff --git a/astro/gpscorrelate/Makefile b/astro/gpscorrelate/Makefile
index 9f580934d129..00fd16b6feb8 100644
--- a/astro/gpscorrelate/Makefile
+++ b/astro/gpscorrelate/Makefile
@@ -13,8 +13,8 @@ COMMENT= Correlate digital camera photos with GPS data in GPX format
LICENSE= GPLv2
-LIB_DEPENDS= exiv2:${PORTSDIR}/graphics/exiv2 \
- gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24
+LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2 \
+ libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24
OPTIONS_DEFINE= DOCS
diff --git a/astro/mymoon/Makefile b/astro/mymoon/Makefile
index adc73a20289a..9298a60cd2f6 100644
--- a/astro/mymoon/Makefile
+++ b/astro/mymoon/Makefile
@@ -12,7 +12,7 @@ MASTER_SITE_SUBDIR= krion
MAINTAINER= ports@FreeBSD.org
COMMENT= Show latitude and longitude of the moon
-LIB_DEPENDS= nova:${PORTSDIR}/astro/libnova
+LIB_DEPENDS= libnova.so:${PORTSDIR}/astro/libnova
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/astro/nightfall/Makefile b/astro/nightfall/Makefile
index 0f553e6cbee9..4721a99d0569 100644
--- a/astro/nightfall/Makefile
+++ b/astro/nightfall/Makefile
@@ -37,7 +37,7 @@ PLIST_SUB+= GNOMEUI="@comment "
.endif
.if ${PORT_OPTIONS:MPGPLOT}
-LIB_DEPENDS+= pgplot.5:${PORTSDIR}/graphics/pgplot
+LIB_DEPENDS+= libpgplot.so:${PORTSDIR}/graphics/pgplot
USE_FORTRAN= yes
CONFIGURE_ARGS+= --with-pgplot-include=${LOCALBASE}/include \
--with-pgplot-lib=${LOCALBASE}/lib
@@ -47,7 +47,7 @@ CONFIGURE_ARGS+= --with-gnuplot
.endif
.if ${PORT_OPTIONS:MOPENGL}
-LIB_DEPENDS+= gtkgl-2.0.1:${PORTSDIR}/x11-toolkits/gtkglarea2
+LIB_DEPENDS+= libgtkgl-2.0.so:${PORTSDIR}/x11-toolkits/gtkglarea2
USE_GL= glut
CONFIGURE_ARGS+= --with-lib-GL
.else
diff --git a/astro/openuniverse/Makefile b/astro/openuniverse/Makefile
index e8c46f5b375b..a2d1b38674cf 100644
--- a/astro/openuniverse/Makefile
+++ b/astro/openuniverse/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1.0beta3
MAINTAINER= ports@FreeBSD.org
COMMENT= OpenGL Solar System simulator for X Window System
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
USE_GL= glut
diff --git a/astro/p5-Astro-FITS-CFITSIO/Makefile b/astro/p5-Astro-FITS-CFITSIO/Makefile
index 4573ca2998ec..7b4810e82db4 100644
--- a/astro/p5-Astro-FITS-CFITSIO/Makefile
+++ b/astro/p5-Astro-FITS-CFITSIO/Makefile
@@ -10,7 +10,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl extension for using the cfitsio library
-LIB_DEPENDS= cfitsio:${PORTSDIR}/astro/cfitsio
+LIB_DEPENDS= libcfitsio.so:${PORTSDIR}/astro/cfitsio
CONFIGURE_ENV= CFITSIO=${LOCALBASE}
USES= perl5
diff --git a/astro/rmap/Makefile b/astro/rmap/Makefile
index 064aec53605d..3acc55283085 100644
--- a/astro/rmap/Makefile
+++ b/astro/rmap/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://www.reza.net/rmap/
MAINTAINER= ports@FreeBSD.org
COMMENT= Generates images of the Earth centered at a particular location
-LIB_DEPENDS= gd:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
GNU_CONFIGURE= yes
USES= gmake
diff --git a/astro/roadmap/Makefile b/astro/roadmap/Makefile
index d6525a41ac4b..0a51234a101b 100644
--- a/astro/roadmap/Makefile
+++ b/astro/roadmap/Makefile
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
COMMENT= Vector-based GPS moving map
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
BUILD_WRKSRC= ${WRKSRC}/src
diff --git a/astro/sunclock/Makefile b/astro/sunclock/Makefile
index 05d25f1ad7e4..ba12017e5922 100644
--- a/astro/sunclock/Makefile
+++ b/astro/sunclock/Makefile
@@ -11,8 +11,8 @@ COMMENT= Shows which portion of the Earth's surface is illuminated by the Sun
LICENSE= GPLv2
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png
USE_BZIP2= yes
USE_XORG= xpm
diff --git a/astro/wcslib/Makefile b/astro/wcslib/Makefile
index 5bce06b62bc7..c0ad010f371d 100644
--- a/astro/wcslib/Makefile
+++ b/astro/wcslib/Makefile
@@ -31,13 +31,13 @@ PGPLOT_DESC= Add pgplot support (for tests only)
.if ${PORT_OPTIONS:MCFITSIO} || exists(${LOCALBASE}/lib/libcfitsio.so)
PLIST_SUB+= HPXCVT=""
-LIB_DEPENDS+= cfitsio:${PORTSDIR}/astro/cfitsio
+LIB_DEPENDS+= libcfitsio.so:${PORTSDIR}/astro/cfitsio
.else
PLIST_SUB+= HPXCVT="@comment "
.endif
.if ${PORT_OPTIONS:MPGPLOT}
-LIB_DEPENDS+= pgplot.5:${PORTSDIR}/graphics/pgplot
+LIB_DEPENDS+= libpgplot.so:${PORTSDIR}/graphics/pgplot
.endif
post-patch:
diff --git a/astro/wmglobe/Makefile b/astro/wmglobe/Makefile
index 40383ef4e2a7..0b3c68a163b9 100644
--- a/astro/wmglobe/Makefile
+++ b/astro/wmglobe/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://hamete.org/static/wmg/
MAINTAINER= will@FreeBSD.org
COMMENT= A neat xearth-like WindowMaker dockapp
-LIB_DEPENDS= wraster.4:${PORTSDIR}/x11-wm/windowmaker
+LIB_DEPENDS= libwraster.so:${PORTSDIR}/x11-wm/windowmaker
NO_STAGE= yes
MAN1= wmglobe.1
diff --git a/astro/xephem/Makefile b/astro/xephem/Makefile
index 3d61ceabd087..38d37c3e1794 100644
--- a/astro/xephem/Makefile
+++ b/astro/xephem/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= # http://www.clearskyinstitute.com/xephem/
MAINTAINER= jpaetzel@FreeBSD.org
COMMENT= An interactive astronomical ephemeris program
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg
NO_STAGE= yes
USES= gmake motif
diff --git a/astro/xmoontool/Makefile b/astro/xmoontool/Makefile
index aa9e08c3aee1..c4346af36f60 100644
--- a/astro/xmoontool/Makefile
+++ b/astro/xmoontool/Makefile
@@ -20,7 +20,7 @@ PLIST_FILES= bin/xmoontool
.if defined(WITHOUT_LIBNOVA)
MAKE_ENV+= WITHOUT_LIBNOVA=yes
.else
-LIB_DEPENDS+= nova:${PORTSDIR}/astro/libnova
+LIB_DEPENDS+= libnova.so:${PORTSDIR}/astro/libnova
.endif
pre-everything::
diff --git a/astro/xplanet/Makefile b/astro/xplanet/Makefile
index 8f30f3962acf..3ab2e32ee911 100644
--- a/astro/xplanet/Makefile
+++ b/astro/xplanet/Makefile
@@ -27,7 +27,7 @@ MAN1= xplanet.1
.if ${PORT_OPTIONS:MFREETYPE}
CONFIGURE_ARGS+= --with-freetype
-LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS+= libfreetype.so:${PORTSDIR}/print/freetype2
.else
CONFIGURE_ARGS+= --without-freetype
.endif
@@ -41,35 +41,35 @@ CONFIGURE_ARGS+= --without-pango
.if ${PORT_OPTIONS:MGIF}
CONFIGURE_ARGS+= --with-gif
-LIB_DEPENDS+= gif.5:${PORTSDIR}/graphics/giflib
+LIB_DEPENDS+= libgif.so:${PORTSDIR}/graphics/giflib
.else
CONFIGURE_ARGS+= --without-gif
.endif
.if ${PORT_OPTIONS:MJPEG}
CONFIGURE_ARGS+= --with-jpeg
-LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
.else
CONFIGURE_ARGS+= --without-jpeg
.endif
.if ${PORT_OPTIONS:MPNG}
CONFIGURE_ARGS+= --with-png
-LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png
.else
CONFIGURE_ARGS+= --without-png
.endif
.if ${PORT_OPTIONS:MPNM}
CONFIGURE_ARGS+= --with-pnm
-LIB_DEPENDS+= netpbm.1:${PORTSDIR}/graphics/netpbm
+LIB_DEPENDS+= libnetpbm.so:${PORTSDIR}/graphics/netpbm
.else
CONFIGURE_ARGS+= --without-pnm
.endif
.if ${PORT_OPTIONS:MTIFF}
CONFIGURE_ARGS+= --with-tiff
-LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS+= libtiff.so:${PORTSDIR}/graphics/tiff
.else
CONFIGURE_ARGS+= --without-tiff
.endif
diff --git a/astro/xtide/Makefile b/astro/xtide/Makefile
index c91cf701dabf..26323be04f58 100644
--- a/astro/xtide/Makefile
+++ b/astro/xtide/Makefile
@@ -16,11 +16,10 @@ COMMENT= Harmonic tide clock and tide predictor
LICENSE= GPLv3
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
USE_BZIP2= yes
USES= gmake
-USE_GCC= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I../${TCD_DISTNAME} -I${LOCALBASE}/include/libpng15 -Wno-deprecated-declarations