aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
Diffstat (limited to 'astro')
-rw-r--r--astro/orsa/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/astro/orsa/Makefile b/astro/orsa/Makefile
index 1c1cc7d14d0b..04d4dcaf760d 100644
--- a/astro/orsa/Makefile
+++ b/astro/orsa/Makefile
@@ -29,4 +29,17 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's,Body::,,' \
+ ${WRKSRC}/src/liborsa/orsa_body.h
+ @${REINPLACE_CMD} -E 's,[[:alnum:]]+::(compare\(),\1,' \
+ ${WRKSRC}/src/libxorsa/xorsa_analysis.h \
+ ${WRKSRC}/src/libxorsa/xorsa_import_astorb_objects.h \
+ ${WRKSRC}/src/libxorsa/xorsa_object_selector.cc \
+ ${WRKSRC}/src/orsa/xorsa.h
+ @${REINPLACE_CMD} -e 's,^extern,& "C",' \
+ ${WRKSRC}/src/libxorsa/xorsa_plot_area.h
+ @${REINPLACE_CMD} -e '/nprintf/s,std::,,' \
+ ${WRKSRC}/src/libxorsa/xorsa_wrapper.cc
+
.include <bsd.port.mk>