aboutsummaryrefslogtreecommitdiffstats
path: root/audio/ardour/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/ardour/Makefile')
-rw-r--r--audio/ardour/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/audio/ardour/Makefile b/audio/ardour/Makefile
index 0a691b1137ba..6bef2ebdf17a 100644
--- a/audio/ardour/Makefile
+++ b/audio/ardour/Makefile
@@ -25,7 +25,6 @@ LIB_DEPENDS= lrdf.2:${PORTSDIR}/textproc/liblrdf \
sqlite3:${PORTSDIR}/databases/sqlite3 \
lo.6:${PORTSDIR}/audio/liblo \
SoundTouch.0:${PORTSDIR}/audio/soundtouch \
- usb:${PORTSDIR}/devel/libusb \
fftw3f:${PORTSDIR}/math/fftw3-float \
fftw3:${PORTSDIR}/math/fftw3 \
aubio.3:${PORTSDIR}/audio/aubio
@@ -53,6 +52,10 @@ OPTIONS= OPTIMIZED_CFLAGS "Builds with compiler optimizations" on \
BROKEN= needs posix_memalign()
.endif
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
+.endif
+
.if defined(WITH_VST)
# Yes, 'PlugIns' is not a typo.
VST_DIST+= vst_sdk2_3.zip