aboutsummaryrefslogtreecommitdiffstats
path: root/audio/aube/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/aube/Makefile')
-rw-r--r--audio/aube/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/audio/aube/Makefile b/audio/aube/Makefile
index 661b69c2b103..d50ad395902c 100644
--- a/audio/aube/Makefile
+++ b/audio/aube/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= aube
-PORTVERSION= 0.30.2
-PORTREVISION= 2
+PORTVERSION= 0.30.3
CATEGORIES= audio gnome
MASTER_SITES= http://www.metadecks.org/software/aube/download/
@@ -17,12 +16,23 @@ COMMENT= System for sound generation and processing
LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile
USE_X_PREFIX= yes
+USE_GNOME= imlib
USE_GMAKE= yes
-GNU_CONFIGURE= yes
-USE_GNOME= gnomeprefix gnomehier gnomehack gtk12 imlib
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= aube.1
+PLIST_FILES= bin/aube \
+ %%DATADIR%%/aube_logo.ppm \
+ %%DATADIR%%/aube_mini.png \
+ %%DATADIR%%/gtkrc
+PLIST_DIRS= %%DATADIR%%
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-lgdk_imlib|@GDK_IMLIB_LIBS@|g' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|-g -O2 -Wall|@CFLAGS@|g' ${WRKSRC}/src/modules/Makefile.in
.include <bsd.port.mk>