aboutsummaryrefslogtreecommitdiffstats
path: root/audio/audacity-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/audacity-devel/Makefile')
-rw-r--r--audio/audacity-devel/Makefile73
1 files changed, 48 insertions, 25 deletions
diff --git a/audio/audacity-devel/Makefile b/audio/audacity-devel/Makefile
index cdab24190fa9..67d086209c30 100644
--- a/audio/audacity-devel/Makefile
+++ b/audio/audacity-devel/Makefile
@@ -5,11 +5,11 @@
# $FreeBSD$
PORTNAME= audacity
-PORTVERSION= 1.3.5
+PORTVERSION= 1.3.7
CATEGORIES= audio
MASTER_SITES= SF
PKGNAMESUFFIX= -devel
-DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+DISTNAME= ${PORTNAME}-fullsrc-${PORTVERSION}
MAINTAINER= xxjack12xx@gmail.com
COMMENT= Audacity is a GUI editor for digital audio waveforms
@@ -19,22 +19,29 @@ LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile
CONFLICTS= audacity-[0-9]*
-WRKSRC= ${WRKDIR}/${PORTNAME}-src-${PORTVERSION}-beta
+WRKSRC= ${WRKDIR}/${PORTNAME}-src-${PORTVERSION}
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GETTEXT= yes
USE_GCC= 4.2+
+USE_GETTEXT= yes
USE_BZIP2= yes
-USE_WX= 2.6
+USE_WX= 2.8
WX_COMPS= wx
+PORTDOCS= README.txt LICENSE.txt
MAN1= audacity.1
MANCOMPRESSED= yes
-OPTIONS= ID3TAG "ID3 tag support" off \
- MAD "Mad MP3 audio decoder support" on \
- VORBIS "OGG/Vorbis audio support" on
+OPTIONS= VORBIS "Use libvorbis for Ogg Vorbis support" on \
+ MAD "Use libmad for mp2/3 decoding support" on \
+ FLAC "Use libFLAC for FLAC support" on \
+ ID3TAG "Use libid3tag for mp3 id3 tag support" on \
+ SBSMS "Use libsbsms for pitch and tempo changing" on \
+ SOUNDTOUCH "Use libsbsms for pitch and tempo changing" on\
+ TWOLAME "Use libtwolame for MP2 export support" on \
+ FFMPEG "Use ffmpeg for import and export support" on \
+ MIDI "Use portSMF for Midi support" on
.include <bsd.port.pre.mk>
@@ -44,34 +51,50 @@ SSE_CFLAGS= -mno-sse -mno-sse2
CONFIGURE_ARG+= --destdir=/
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
- CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}" \
- CFLAGS="${CFLAGS} -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}" \
+ CPPFLAGS="${CPPFLAGS} -I${WRKSRC}/lib-src/portaudio-v19/include -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}" \
+ CFLAGS="${CFLAGS} -I${WRKSRC}/lib-src/portaudio-v19/include -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}" \
WX_CONFIG=${WX_CONFIG}
.if !defined(NOPORTDOCS)
MAKE_ENV= DOC=yes
.endif
-CONFIGURE_ARGS+= --with-portaudio=v18
-.if !defined(WITHOUT_MAD)
-CONFIGURE_ARGS+= --with-libmad=system
-LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
-.else
-CONFIGURE_ARGS+= --without-libmad
+CONFIGURE_ARGS+= --enable-unicode=no
+
+.if defined(WITH_VORBIS)
+CONFIGURE_ARGS+= --with-libvorbis
+.endif
+
+.if defined(WITH_MAD)
+CONFIGURE_ARGS+= --with-libmad
.endif
-.if !defined(WITHOUT_VORBIS)
-CONFIGURE_ARGS+= --with-vorbis=system
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
-.else
-CONFIGURE_ARGS+= --without-vorbis
+.if defined(WITH_FLAC)
+CONFIGURE_ARGS+= --with-libflac
.endif
.if defined(WITH_ID3TAG)
-CONFIGURE_ARGS+= --with-id3tag=system
-LIB_DEPENDS+= id3tag.0:${PORTSDIR}/audio/libid3tag
-.else
-CONFIGURE_ARGS+= --without-id3tag
+CONFIGURE_ARGS+= --with-libid3tag
+.endif
+
+.if defined(WITH_SBSMS)
+CONFIGURE_ARGS+= --with-sbsms
+.endif
+
+.if defined(WITH_SOUNDTOUCH)
+CONFIGURE_ARGS+= --with-soundtouch
+.endif
+
+.if defined(WITH_TWOLAME)
+CONFIGURE_ARGS+= --with-libtwolame
+.endif
+
+.if defined(WITH_FFMPEG)
+CONFIGURE_ARGS+= --with-ffmpeg
+.endif
+
+.if defined(WITH_MIDI)
+CONFIGURE_ARGS+= --with-midi
.endif
.include <bsd.port.post.mk>