aboutsummaryrefslogtreecommitdiffstats
path: root/audio/audacity-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/audacity-devel/Makefile')
-rw-r--r--audio/audacity-devel/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/audio/audacity-devel/Makefile b/audio/audacity-devel/Makefile
index 1f3a8d364d97..f1b10d1b0b89 100644
--- a/audio/audacity-devel/Makefile
+++ b/audio/audacity-devel/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= audacity
-PORTVERSION= 1.3.0b
+PORTVERSION= 1.3.2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -25,6 +25,9 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GETTEXT= yes
+USE_GCC= 4.1
+
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
MAN1= audacity.1
MANCOMPRESSED= yes
@@ -48,6 +51,7 @@ CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
MAKE_ENV= DOC=yes
.endif
+CONFIGURE_ARGS+= --with-portaudio=v18
.if !defined(WITHOUT_MAD)
CONFIGURE_ARGS+= --with-libmad=system
LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
@@ -69,4 +73,8 @@ LIB_DEPENDS+= id3tag.0:${PORTSDIR}/audio/libid3tag
CONFIGURE_ARGS+= --without-id3tag
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's,^sndfile.c : .*,,' \
+ ${WRKSRC}/lib-src/libsndfile/src/Makefile.in
+
.include <bsd.port.post.mk>