aboutsummaryrefslogtreecommitdiffstats
path: root/audio/blop/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/blop/Makefile')
-rw-r--r--audio/blop/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/audio/blop/Makefile b/audio/blop/Makefile
index 006dfe539c5b..745cbc9b708a 100644
--- a/audio/blop/Makefile
+++ b/audio/blop/Makefile
@@ -3,10 +3,9 @@
# Whom: Tilman Linneweh <freebsdports@arved.de>
#
# $FreeBSD$
-#
PORTNAME= blop
-PORTVERSION= 0.1.0
+PORTVERSION= 0.2.5
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,15 +15,16 @@ MAINTAINER= freebsdports@arved.de
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
-PLUGINS= sawtooth.so \
- square.so \
- pulse.so \
- triangle.so
-PLUGIN_DIR= ${LOCALBASE}/lib/ladspa
+USE_GMAKE= yes
+USE_AUTOMAKE= yes
+USE_AUTOCONF= yes
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+MAKE_ENV= LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+AUTOMAKE_ARGS= --add-missing
-do-install:
-.for file in ${PLUGINS}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${PLUGIN_DIR}
-.endfor
+pre-build:
+ cd ${WRKSRC}/src; ${GMAKE} sawtooth_data.h square_data.h parabola_data.h
.include <bsd.port.mk>