aboutsummaryrefslogtreecommitdiffstats
path: root/audio/daaplib
diff options
context:
space:
mode:
Diffstat (limited to 'audio/daaplib')
-rw-r--r--audio/daaplib/Makefile33
-rw-r--r--audio/daaplib/distinfo1
-rw-r--r--audio/daaplib/pkg-descr5
-rw-r--r--audio/daaplib/pkg-plist6
4 files changed, 45 insertions, 0 deletions
diff --git a/audio/daaplib/Makefile b/audio/daaplib/Makefile
new file mode 100644
index 000000000000..8fd494855bed
--- /dev/null
+++ b/audio/daaplib/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: daaplib
+# Date created: 19 October 2003
+# Whom: Lars Thegler <lars@thegler.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= daaplib
+PORTVERSION= 0.1.1a
+CATEGORIES= audio
+MASTER_SITES= http://www.deleet.de/projekte/daap/daaplib/
+DISTNAME= ${PORTNAME}.${PORTVERSION}
+
+MAINTAINER= lars@thegler.dk
+COMMENT= A C++ library for DAAP memory streams
+
+USE_ZIP= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/daaplib/src
+MAKEFILE= makefile
+ALL_TARGET=
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/${MAKEFILE}
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/daaplib/distinfo b/audio/daaplib/distinfo
new file mode 100644
index 000000000000..85f72a3e2f53
--- /dev/null
+++ b/audio/daaplib/distinfo
@@ -0,0 +1 @@
+MD5 (daaplib.0.1.1a.zip) = 038df4ac53780074e6e642a6e928f4fb
diff --git a/audio/daaplib/pkg-descr b/audio/daaplib/pkg-descr
new file mode 100644
index 000000000000..3907fa3dd96e
--- /dev/null
+++ b/audio/daaplib/pkg-descr
@@ -0,0 +1,5 @@
+daaplib is a very tiny and portable C++ library which helps to read and
+write low-level DAAP stream s in memory. the code is fairly
+straightforward and can mirror the structure of the data fairly well.
+
+WWW: http://www.deleet.de/projekte/daap/daaplib/
diff --git a/audio/daaplib/pkg-plist b/audio/daaplib/pkg-plist
new file mode 100644
index 000000000000..59dc4a5d62a5
--- /dev/null
+++ b/audio/daaplib/pkg-plist
@@ -0,0 +1,6 @@
+include/daap/basic.h
+include/daap/registry.h
+include/daap/taginput.h
+include/daap/tagoutput.h
+lib/libdaaplib.a
+%%PORTDOCS%%%%DOCSDIR%%/README