aboutsummaryrefslogtreecommitdiffstats
path: root/audio/eawpats/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/eawpats/Makefile')
-rw-r--r--audio/eawpats/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/audio/eawpats/Makefile b/audio/eawpats/Makefile
new file mode 100644
index 000000000000..3574688b9b59
--- /dev/null
+++ b/audio/eawpats/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: eawpats
+# Date created: 3 September 2003
+# Whom: Jonathan Lennox <lennox@cs.columbia.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eawpats
+PORTVERSION= 12
+CATEGORIES= audio
+MASTER_SITES= http://madchat.org/music/ \
+ http://5hdumat.samizdat.net/music/
+DISTNAME= eawpats12_full
+
+MAINTAINER= lennox@cs.columbia.edu
+COMMENT= Eric A. Welsh's collection of Gravis Ultrasound MIDI patches
+
+# Not useful without timidity.
+RUN_DEPENDS= timidity:${PORTSDIR}/audio/timidity++
+
+RESTRICTED= Some of the patches are marked no-commercial-use
+
+NO_BUILD= yes
+USE_REINPLACE= yes
+
+PATCH_SUBDIRS= ethnic mazpat/fx gsdrum08 gsdrum25 gsdrum40 gus power sfx wime
+DOC_SUBDIRS= ethnic gsdrum08 gsdrum25 gsdrum40 power wime
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+TIMIDITY_DATADIR= ${PREFIX}/share/timidity
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/home/user/eawpats|${DATADIR}|' ${WRKSRC}/linuxconfig/timidity.cfg
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.cfg ${WRKSRC}/*.pat ${WRKSRC}/*.ini ${DATADIR}
+.for subdir in ${PATCH_SUBDIRS}
+ ${MKDIR} ${DATADIR}/${subdir}
+ ${INSTALL_DATA} ${WRKSRC}/${subdir}/*.pat ${DATADIR}/${subdir}
+.endfor
+ ${MKDIR} ${TIMIDITY_DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/linuxconfig/timidity.cfg ${TIMIDITY_DATADIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/*.txt ${WRKSRC}/*.hlp ${DOCSDIR}
+.for subdir in ${DOC_SUBDIRS}
+ ${MKDIR} ${DOCSDIR}/${subdir}
+ ${INSTALL_MAN} ${WRKSRC}/${subdir}/*.txt ${DOCSDIR}/${subdir}
+.endfor
+.endif
+
+.include <bsd.port.mk>