aboutsummaryrefslogtreecommitdiffstats
path: root/audio/emms/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/emms/Makefile')
-rw-r--r--audio/emms/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/audio/emms/Makefile b/audio/emms/Makefile
new file mode 100644
index 000000000000..25e4d205a223
--- /dev/null
+++ b/audio/emms/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: emms
+# Date created: 10 May 2006
+# Whom: Dryice Liu <dryice@dryice.name>
+#
+# $FreeBSD$
+#
+
+PORTNAME= emms
+PORTVERSION= 2.0
+CATEGORIES= audio elisp
+MASTER_SITES= http://www.gnu.org/software/emms/releases/ \
+ http://dryice.name/computer/FreeBSD/distfiles/
+
+MAINTAINER= dryice@dryice.name
+COMMENT= EMMS is the Emacs Multi-Media System
+
+USE_EMACS= yes
+EMACS_PORT_NAME?= emacs21
+
+.if ${EMACS_PORT_NAME} != "emacs21"
+PORTNAMESUFFIX= ${PKGNAMESUFFIX}
+.endif
+
+USE_GMAKE= yes
+MAKE_ENV+= EMACS_SITE_LISPDIR=${EMACS_SITE_LISPDIR}
+INFO= emms
+MAN1= emms-print-metadata.1
+
+.include <bsd.port.mk>