aboutsummaryrefslogtreecommitdiffstats
path: root/audio/extace/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/extace/Makefile')
-rw-r--r--audio/extace/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/audio/extace/Makefile b/audio/extace/Makefile
index 0975d841e04a..7c26512c28c7 100644
--- a/audio/extace/Makefile
+++ b/audio/extace/Makefile
@@ -6,28 +6,31 @@
#
PORTNAME= extace
-PORTVERSION= 1.7.3
+PORTVERSION= 1.7.8
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= extace
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= An Audio Visualization plugin for the X Window System
LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw
-.include <bsd.port.pre.mk>
-
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix gtk12 imlib esound
USE_REINPLACE= yes
USE_LIBTOOL= yes
CONFIGURE_ARGS+= --disable-alsa
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DHAVE_LIBFFTW" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -DHAVE_LIBFFTW" \
+ LDFLAGS="-L${LOCALBASE}/lib"
post-patch:
@${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" \
-e "s|DATADIRNAME=lib|DATADIRNAME=share|g" ${WRKSRC}/configure
-.include <bsd.port.post.mk>
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/extace ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/src/extace.desktop \
+ ${PREFIX}/share/gnome/apps/Multimedia
+
+.include <bsd.port.mk>