aboutsummaryrefslogtreecommitdiffstats
path: root/audio/festlex-cmu
diff options
context:
space:
mode:
Diffstat (limited to 'audio/festlex-cmu')
-rw-r--r--audio/festlex-cmu/Makefile36
-rw-r--r--audio/festlex-cmu/distinfo3
-rw-r--r--audio/festlex-cmu/pkg-comment1
-rw-r--r--audio/festlex-cmu/pkg-descr2
-rw-r--r--audio/festlex-cmu/pkg-plist12
5 files changed, 54 insertions, 0 deletions
diff --git a/audio/festlex-cmu/Makefile b/audio/festlex-cmu/Makefile
new file mode 100644
index 000000000000..18b4cc6d57b0
--- /dev/null
+++ b/audio/festlex-cmu/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: festlex-cmu
+# Date created: 2000-06-15
+# Whom: Trevor Johnson <trevor@jpj.net>
+# based on the NetBSD port
+#
+# $NetBSD: Makefile,v 1.7 1999/12/28 04:19:58 wiz Exp $
+# $FreeBSD$
+#
+
+PORTNAME= festlex-cmu
+PORTVERSION= 1.4.1
+CATEGORIES= audio
+MASTER_SITES= http://www.speech.cs.cmu.edu/festival/cstr/festival/1.4.1/ \
+ ftp://ftp.cstr.ed.ac.uk/pub/festival/1.4.1/
+DISTNAME= festlex_CMU
+DIST_SUBDIR= festival
+
+MAINTAINER= trevor@jpj.net
+
+RUN_DEPENDS= festival:../festival
+
+WRKSRC= ${WRKDIR}/festival
+
+NO_BUILD= yes
+
+FHOME= ${PREFIX}/share/festival
+
+post-extract:
+ @ ${CHMOD} -R a+r ${WRKSRC}
+ @ find ${WRKSRC} -type d -print0 | xargs -0 ${CHMOD} 755
+
+do-install:
+ ${MKDIR} ${FHOME}
+ cd ${WRKSRC} && ${CP} -pPR * ${FHOME}
+
+.include <bsd.port.mk>
diff --git a/audio/festlex-cmu/distinfo b/audio/festlex-cmu/distinfo
new file mode 100644
index 000000000000..e190305d0649
--- /dev/null
+++ b/audio/festlex-cmu/distinfo
@@ -0,0 +1,3 @@
+$NetBSD: md5,v 1.2 1999/10/11 16:30:53 proff Exp $
+
+MD5 (festival/festlex_CMU.tar.gz) = a3ffcd09dcbf1306fdef3c84c1c521d6
diff --git a/audio/festlex-cmu/pkg-comment b/audio/festlex-cmu/pkg-comment
new file mode 100644
index 000000000000..1c4decd9466d
--- /dev/null
+++ b/audio/festlex-cmu/pkg-comment
@@ -0,0 +1 @@
+CMU American English pronunciation dictionary for Festival
diff --git a/audio/festlex-cmu/pkg-descr b/audio/festlex-cmu/pkg-descr
new file mode 100644
index 000000000000..843fb787699e
--- /dev/null
+++ b/audio/festlex-cmu/pkg-descr
@@ -0,0 +1,2 @@
+CMU American English pronunciation dictionary for the Festival
+speech synthesis system
diff --git a/audio/festlex-cmu/pkg-plist b/audio/festlex-cmu/pkg-plist
new file mode 100644
index 000000000000..f710a8721ded
--- /dev/null
+++ b/audio/festlex-cmu/pkg-plist
@@ -0,0 +1,12 @@
+@comment $NetBSD: PLIST,v 1.3 1999/10/27 15:34:11 hubertf Exp $
+share/festival/lib/dicts/cmu/cmulex.scm
+share/festival/lib/dicts/cmu/cmu_lts_rules.scm
+share/festival/lib/dicts/cmu/cmudict-0.4.out
+share/festival/lib/dicts/cmu/Makefile
+share/festival/lib/dicts/cmu/cmudict-0.4.scm
+share/festival/lib/dicts/cmu/cmudict-0.4.diff
+share/festival/lib/dicts/cmu/cmu2ft
+share/festival/lib/dicts/cmu/cmudict_extensions.scm
+share/festival/lib/dicts/cmu/COPYING
+@dirrm share/festival/lib/dicts/cmu
+@dirrm share/festival/lib/dicts